summaryrefslogtreecommitdiff
path: root/support/texlab/Cargo.toml
diff options
context:
space:
mode:
authorNorbert Preining <norbert@preining.info>2021-05-23 03:00:39 +0000
committerNorbert Preining <norbert@preining.info>2021-05-23 03:00:39 +0000
commitf1261b349e875b842745b63258c3e338cb1fe3bf (patch)
treeb5d402b3e80818cde2c079a42249f3dcb9732247 /support/texlab/Cargo.toml
parent58aa1ac09b1d9e4769d0a0661cf12e2b2db41b14 (diff)
CTAN sync 202105230300
Diffstat (limited to 'support/texlab/Cargo.toml')
-rw-r--r--support/texlab/Cargo.toml125
1 files changed, 45 insertions, 80 deletions
diff --git a/support/texlab/Cargo.toml b/support/texlab/Cargo.toml
index 3855dbf32d..56317c7f9c 100644
--- a/support/texlab/Cargo.toml
+++ b/support/texlab/Cargo.toml
@@ -1,7 +1,7 @@
[package]
name = "texlab"
description = "LaTeX Language Server"
-version = "2.2.1"
+version = "3.0.1"
license = "GPL-3.0"
readme = "README.md"
authors = [
@@ -11,101 +11,66 @@ authors = [
edition = "2018"
homepage = "https://texlab.netlify.app"
-[workspace]
-members = ["crates/*"]
-
[lib]
doctest = false
[features]
-default = [
- "citation",
- "server",
- "test",
-]
-citation = [
- "bibutils-sys",
- "citeproc",
- "citeproc-db",
- "citeproc-io",
- "csl",
- "fnv",
- "html2md",
- "lalrpop/lexer",
- "lalrpop-util",
-]
-server = [
- "bytes",
- "jsonrpc",
- "jsonrpc-derive",
- "nom",
- "tokio-util/codec",
-]
-test = [
- "server",
- "aovec",
-]
-
-[[bin]]
-name = "texlab"
-required-features = ["server"]
-
-[[test]]
-name = "integration"
-required-features = ["test"]
+default = ["citation", "completion"]
+completion = ["fuzzy-matcher"]
+citation = ["bibutils-sys", "citeproc", "citeproc-db", "citeproc-io", "csl", "fnv", "html2md", "lalrpop-util", "lalrpop"]
+semantic = []
[dependencies]
-async-trait = "0.1"
-aovec = { version = "1.1", optional = true }
-base64 = "0.13"
-bibutils-sys = { version = "0.1", optional = true }
-byteorder = "1.3"
-bytes = { version = "0.5", optional = true }
-chashmap = "2.2"
-cfg-if = "0.1"
+anyhow = "1.0.40"
+bibutils-sys = { version = "0.1.1", optional = true }
+byteorder = "1.4.3"
+cancellation = "0.1"
+cfg-if = "1.0.0"
+chashmap = "2.2.2"
citeproc = { git = "https://github.com/cormacrelf/citeproc-rs", rev = "68c7a7c16088b5d7751641ab37299ad064cdb221", optional = true }
citeproc-db = { git = "https://github.com/cormacrelf/citeproc-rs", rev = "68c7a7c16088b5d7751641ab37299ad064cdb221", optional = true }
citeproc-io = { git = "https://github.com/cormacrelf/citeproc-rs", rev = "68c7a7c16088b5d7751641ab37299ad064cdb221", optional = true }
csl = { git = "https://github.com/cormacrelf/citeproc-rs", rev = "68c7a7c16088b5d7751641ab37299ad064cdb221", optional = true }
+crossbeam-channel = "0.5.1"
+cstree = "0.5.0"
+derive_more = "0.99.14"
+encoding_rs = "0.8.28"
+encoding_rs_io = "0.1.7"
fern = "0.6"
fnv = { version = "1.0", optional = true }
-futures = "0.3"
-fuzzy-matcher = "0.3"
-html2md = { version = "0.2", optional = true }
-image = "0.23"
-itertools = "0.9"
-jsonrpc = { path = "crates/jsonrpc", optional = true }
-jsonrpc-derive = { path = "crates/jsonrpc_derive", optional = true }
-lalrpop-util = { version = "0.18", optional = true }
-log = "0.4"
-lsp-types = { version = "0.74.1" }
-nom = { version = "6.0", optional = true }
-once_cell = "1.4"
-petgraph = { version = "0.5", features = ["serde-1"] }
-rayon = "1.5"
-regex = "1.3"
-serde = { version = "1.0", features = ["derive", "rc"] }
-serde_json = "1.0"
-serde_repr = "0.1"
+fuzzy-matcher = { version = "0.3.7", optional = true }
+html2md = { version = "0.2.11", optional = true }
+itertools = "0.10.0"
+lalrpop-util = { version = "0.19.5", optional = true }
+log = "0.4.14"
+logos = "0.12.0"
+lsp-server = "0.5"
+lsp-types = "0.89.0"
+multimap = "0.8.3"
+notify = "5.0.0-pre.8"
+once_cell = "1.7.2"
+petgraph = "0.5.1"
+rayon = "1.5.0"
+regex = "1.5.4"
+rustc-hash = "1.1.0"
+serde = "1.0.126"
+serde_json = "1.0.64"
+serde_repr = "0.1.7"
+smol_str = { version = "0.1.17", features = ["serde"] }
structopt = "0.3"
-tempfile = "3.1"
-thiserror = "1.0"
-titlecase = "1.1"
-tokio = { version = "0.2", features = ["fs", "io-std", "macros", "process", "rt-core", "time"] }
-tokio-util = { version = "0.3", optional = true }
-url = "2.1"
-uuid = { version = "0.8", features = ["v4"] }
+tempfile = "3.2.0"
+threadpool = "1.8.1"
+titlecase = "1.1.0"
+url = "2.2.2"
[dev-dependencies]
-criterion = "0.3"
-indoc = "1.0"
+indoc = "1.0.3"
+insta = "1.7.1"
+typed-builder = "0.9.0"
+unindent = "0.1.7"
[build-dependencies]
-lalrpop = { version = "0.18", optional = true }
+lalrpop = { version = "0.19.5", features = ["lexer"], optional = true }
[profile.release]
-lto = true
-
-[[bench]]
-name = "bench_main"
-harness = false
+lto = true \ No newline at end of file