summaryrefslogtreecommitdiff
path: root/support/texlab/Cargo.toml
diff options
context:
space:
mode:
authorNorbert Preining <norbert@preining.info>2022-06-13 03:03:42 +0000
committerNorbert Preining <norbert@preining.info>2022-06-13 03:03:42 +0000
commitef6d63ded56fb892decaa8ab41d7deebbe670473 (patch)
tree9c8eccf2e633fcfe0ad512e5428222ce0707971e /support/texlab/Cargo.toml
parent86d0c4c6729cfb43e13fb29790810c3cc2521806 (diff)
CTAN sync 202206130303
Diffstat (limited to 'support/texlab/Cargo.toml')
-rw-r--r--support/texlab/Cargo.toml26
1 files changed, 15 insertions, 11 deletions
diff --git a/support/texlab/Cargo.toml b/support/texlab/Cargo.toml
index df04cfba31..f85c0f31ed 100644
--- a/support/texlab/Cargo.toml
+++ b/support/texlab/Cargo.toml
@@ -1,7 +1,7 @@
[package]
name = "texlab"
description = "LaTeX Language Server"
-version = "4.0.0"
+version = "4.1.0"
license = "GPL-3.0"
readme = "README.md"
authors = [
@@ -26,6 +26,10 @@ exclude = [
"texlab.tex",
]
+[[bin]]
+name = "texlab"
+test = false
+
[lib]
doctest = false
@@ -47,20 +51,20 @@ derive_more = "0.99.17"
encoding_rs = "0.8.31"
encoding_rs_io = "0.1.7"
fern = "0.6"
-flate2 = "1.0.23"
+flate2 = "1.0.24"
fuzzy-matcher = { version = "0.3.7", optional = true }
human_name = { version = "1.0.3", default-features = false }
isocountry = "0.3.2"
itertools = "0.10.1"
log = "0.4.17"
-logos = "0.12.0"
+logos = "0.12.1"
lsp-server = "0.6.0"
lsp-types = "0.93.0"
multimap = "0.8.3"
once_cell = "1.10.0"
-petgraph = "0.6.0"
+petgraph = "0.6.2"
regex = "1.5.5"
-rowan = "0.15.4"
+rowan = "0.15.5"
rustc-hash = "1.1.0"
serde = "1.0.137"
serde_json = "1.0.81"
@@ -72,17 +76,17 @@ threadpool = "1.8.1"
titlecase = "1.1.0"
unicode-normalization = "0.1.19"
url = { version = "2.2.2", features = ["serde"] }
-uuid = { version = "1.0.0", features = ["v4"] }
+uuid = { version = "1.1.2", features = ["v4"] }
[dev-dependencies]
+assert_unordered = "0.3.5"
criterion = { version = "0.3.5" }
-indoc = "1.0.6"
-insta = { version = "1.14.0", features = ["backtrace"] }
-typed-builder = "0.10.0"
-unindent = "0.1.9"
+insta = { version = "1.14.1", features = ["backtrace", "redactions"] }
+jod-thread = "0.1.2"
[profile.release]
-lto = "fat"
+lto = "thin"
+incremental = true
[profile.bench]
lto = "thin"