summaryrefslogtreecommitdiff
path: root/support/texlab/Cargo.toml
diff options
context:
space:
mode:
authorNorbert Preining <norbert@preining.info>2021-06-04 03:02:48 +0000
committerNorbert Preining <norbert@preining.info>2021-06-04 03:02:48 +0000
commita5ae129f3aa3a3a0aeaa21c55b75a1d543fe4111 (patch)
treefe5e1e212aec203e668df8581a17374cdde352a1 /support/texlab/Cargo.toml
parentd231c6331f53a048d29c2f847254a9f56d5ee2dd (diff)
CTAN sync 202106040302
Diffstat (limited to 'support/texlab/Cargo.toml')
-rw-r--r--support/texlab/Cargo.toml22
1 files changed, 16 insertions, 6 deletions
diff --git a/support/texlab/Cargo.toml b/support/texlab/Cargo.toml
index 56317c7f9c..506b454b4a 100644
--- a/support/texlab/Cargo.toml
+++ b/support/texlab/Cargo.toml
@@ -1,7 +1,7 @@
[package]
name = "texlab"
description = "LaTeX Language Server"
-version = "3.0.1"
+version = "3.1.0"
license = "GPL-3.0"
readme = "README.md"
authors = [
@@ -17,7 +17,17 @@ doctest = false
[features]
default = ["citation", "completion"]
completion = ["fuzzy-matcher"]
-citation = ["bibutils-sys", "citeproc", "citeproc-db", "citeproc-io", "csl", "fnv", "html2md", "lalrpop-util", "lalrpop"]
+citation = [
+ "bibutils-sys",
+ "citeproc",
+ "citeproc-db",
+ "citeproc-io",
+ "csl",
+ "fnv",
+ "html2md",
+ "lalrpop-util",
+ "lalrpop",
+]
semantic = []
[dependencies]
@@ -45,12 +55,12 @@ lalrpop-util = { version = "0.19.5", optional = true }
log = "0.4.14"
logos = "0.12.0"
lsp-server = "0.5"
-lsp-types = "0.89.0"
+lsp-types = "0.89.1"
multimap = "0.8.3"
-notify = "5.0.0-pre.8"
+notify = "5.0.0-pre.9"
once_cell = "1.7.2"
petgraph = "0.5.1"
-rayon = "1.5.0"
+rayon = "1.5.1"
regex = "1.5.4"
rustc-hash = "1.1.0"
serde = "1.0.126"
@@ -73,4 +83,4 @@ unindent = "0.1.7"
lalrpop = { version = "0.19.5", features = ["lexer"], optional = true }
[profile.release]
-lto = true \ No newline at end of file
+lto = true