summaryrefslogtreecommitdiff
path: root/support/texlab/Cargo.toml
diff options
context:
space:
mode:
authorNorbert Preining <norbert@preining.info>2022-12-30 03:01:26 +0000
committerNorbert Preining <norbert@preining.info>2022-12-30 03:01:26 +0000
commit844019377157163b461e0fd4a66592e61963a530 (patch)
tree32f61991c6a5acc3a3359ffc2cdefdd2aa004268 /support/texlab/Cargo.toml
parent55c69feeef908f49007708be194b7bb1c607f302 (diff)
CTAN sync 202212300301
Diffstat (limited to 'support/texlab/Cargo.toml')
-rw-r--r--support/texlab/Cargo.toml71
1 files changed, 35 insertions, 36 deletions
diff --git a/support/texlab/Cargo.toml b/support/texlab/Cargo.toml
index 803f280e39..62e487b394 100644
--- a/support/texlab/Cargo.toml
+++ b/support/texlab/Cargo.toml
@@ -1,7 +1,7 @@
[package]
name = "texlab"
description = "LaTeX Language Server"
-version = "4.2.0"
+version = "5.0.0"
license = "GPL-3.0"
readme = "README.md"
authors = [
@@ -9,7 +9,7 @@ authors = [
"Patrick Förster <patrick.foerster@outlook.de>",
]
edition = "2021"
-rust-version = "1.58.1"
+rust-version = "1.60"
homepage = "https://github.com/latex-lsp/texlab"
repository = "https://github.com/latex-lsp/texlab"
documentation = "https://github.com/latex-lsp/texlab"
@@ -33,55 +33,54 @@ test = false
[lib]
doctest = false
-[features]
-default = ["completion"]
-completion = ["fuzzy-matcher"]
-
[dependencies]
-anyhow = "1.0.58"
-byteorder = "1.4.3"
-chrono = { version = "0.4.19", default-features = false, features = ["std"] }
-clap = { version = "3.2.8", features = [
- "std",
- "derive",
-], default-features = false }
-crossbeam-channel = "0.5.5"
-dashmap = "~5.2.0"
-derive_more = "0.99.17"
+anyhow = "1.0.66"
+chrono = { version = "0.4.23", default-features = false, features = ["std"] }
+clap = { version = "4.0.29", features = ["derive"] }
+crossbeam-channel = "0.5.6"
+dashmap = "5.4.0"
+dirs = "4.0.0"
encoding_rs = "0.8.31"
encoding_rs_io = "0.1.7"
-fern = "0.6"
-flate2 = "1.0.24"
-fuzzy-matcher = { version = "0.3.7", optional = true }
-human_name = { version = "1.0.3", default-features = false }
+fern = "0.6.1"
+flate2 = "1.0.25"
+flume = "0.10.14"
+fuzzy-matcher = { version = "0.3.7", features = ["compact"] }
+human_name = { version = "2.0.1", default-features = false }
isocountry = "0.3.2"
-itertools = "0.10.1"
+itertools = "0.10.5"
log = "0.4.17"
logos = "0.12.1"
lsp-server = "0.6.0"
-lsp-types = "0.93.0"
-once_cell = "1.10.0"
-petgraph = "0.6.2"
-regex = "1.5.5"
-rowan = "0.15.5"
+lsp-types = { version = "0.93.2", features = ["proposed"] }
+notify = "5.0.0"
+once_cell = "1.16.0"
+regex = "1.7.0"
+rowan = "0.15.10"
rustc-hash = "1.1.0"
-serde = "1.0.137"
-serde_json = "1.0.82"
+serde = "1.0.151"
+serde_json = "1.0.90"
+serde_millis = "0.1.1"
serde_regex = "1.1.0"
-serde_repr = "0.1.8"
+serde_repr = "0.1.10"
smol_str = { version = "0.1.23", features = ["serde"] }
-strum = { version = "0.24.0", features = ["derive"] }
+strum = { version = "0.24.1", features = ["derive"] }
tempfile = "3.3.0"
+thiserror = "1.0.38"
threadpool = "1.8.1"
-titlecase = "2.0.0"
-unicode-normalization = "0.1.20"
-url = { version = "2.2.2", features = ["serde"] }
-uuid = { version = "1.1.2", features = ["v4"] }
+titlecase = "2.2.1"
+unicode-normalization = "0.1.22"
+
+[dependencies.salsa]
+git = "https://github.com/salsa-rs/salsa"
+rev = "20c7834ff34fd00a41b59bec61f3d5c85ea3abd4"
+package = "salsa-2022"
[dev-dependencies]
assert_unordered = "0.3.5"
-criterion = { version = "0.3.5" }
-insta = { version = "1.15.0", features = ["backtrace", "redactions"] }
+criterion = { version = "0.4.0" }
+env_logger = "0.10.0"
+insta = { version = "1.23.0", features = ["glob", "redactions", "json"] }
jod-thread = "0.1.2"
[profile.release]