summaryrefslogtreecommitdiff
path: root/support/texlab/Cargo.toml
diff options
context:
space:
mode:
authorNorbert Preining <norbert@preining.info>2023-01-22 03:01:36 +0000
committerNorbert Preining <norbert@preining.info>2023-01-22 03:01:36 +0000
commit328cc6eb536476a95a84cd7de863b32cabc41b0e (patch)
tree6ce563a6c5075adedee625e648ab6e1fd86a0052 /support/texlab/Cargo.toml
parent94c0d48361932b4beca57cc5609d26a46270dfeb (diff)
CTAN sync 202301220301
Diffstat (limited to 'support/texlab/Cargo.toml')
-rw-r--r--support/texlab/Cargo.toml20
1 files changed, 10 insertions, 10 deletions
diff --git a/support/texlab/Cargo.toml b/support/texlab/Cargo.toml
index 62e487b394..480f16aa94 100644
--- a/support/texlab/Cargo.toml
+++ b/support/texlab/Cargo.toml
@@ -1,7 +1,7 @@
[package]
name = "texlab"
description = "LaTeX Language Server"
-version = "5.0.0"
+version = "5.1.0"
license = "GPL-3.0"
readme = "README.md"
authors = [
@@ -9,7 +9,7 @@ authors = [
"Patrick Förster <patrick.foerster@outlook.de>",
]
edition = "2021"
-rust-version = "1.60"
+rust-version = "1.64"
homepage = "https://github.com/latex-lsp/texlab"
repository = "https://github.com/latex-lsp/texlab"
documentation = "https://github.com/latex-lsp/texlab"
@@ -34,9 +34,9 @@ test = false
doctest = false
[dependencies]
-anyhow = "1.0.66"
+anyhow = "1.0.68"
chrono = { version = "0.4.23", default-features = false, features = ["std"] }
-clap = { version = "4.0.29", features = ["derive"] }
+clap = { version = "4.0.32", features = ["derive"] }
crossbeam-channel = "0.5.6"
dashmap = "5.4.0"
dirs = "4.0.0"
@@ -51,15 +51,15 @@ isocountry = "0.3.2"
itertools = "0.10.5"
log = "0.4.17"
logos = "0.12.1"
-lsp-server = "0.6.0"
+lsp-server = "0.7.0"
lsp-types = { version = "0.93.2", features = ["proposed"] }
notify = "5.0.0"
-once_cell = "1.16.0"
-regex = "1.7.0"
+once_cell = "1.17.0"
+regex = "1.7.1"
rowan = "0.15.10"
rustc-hash = "1.1.0"
-serde = "1.0.151"
-serde_json = "1.0.90"
+serde = "1.0.152"
+serde_json = "1.0.91"
serde_millis = "0.1.1"
serde_regex = "1.1.0"
serde_repr = "0.1.10"
@@ -80,7 +80,7 @@ package = "salsa-2022"
assert_unordered = "0.3.5"
criterion = { version = "0.4.0" }
env_logger = "0.10.0"
-insta = { version = "1.23.0", features = ["glob", "redactions", "json"] }
+insta = { version = "1.26.0", features = ["glob", "redactions", "json"] }
jod-thread = "0.1.2"
[profile.release]