summaryrefslogtreecommitdiff
path: root/support/texlab/Cargo.toml
diff options
context:
space:
mode:
authorNorbert Preining <norbert@preining.info>2022-07-04 03:03:43 +0000
committerNorbert Preining <norbert@preining.info>2022-07-04 03:03:43 +0000
commit1c10375ec46d7d83b2f1efc2a71b7ea114c889f0 (patch)
tree47b3469111105b7767111dcb89858fbc1e73377f /support/texlab/Cargo.toml
parent34d318af65decbdb242ae03b64bf3f53266067b6 (diff)
CTAN sync 202207040303
Diffstat (limited to 'support/texlab/Cargo.toml')
-rw-r--r--support/texlab/Cargo.toml42
1 files changed, 21 insertions, 21 deletions
diff --git a/support/texlab/Cargo.toml b/support/texlab/Cargo.toml
index f85c0f31ed..803f280e39 100644
--- a/support/texlab/Cargo.toml
+++ b/support/texlab/Cargo.toml
@@ -1,12 +1,12 @@
[package]
name = "texlab"
description = "LaTeX Language Server"
-version = "4.1.0"
+version = "4.2.0"
license = "GPL-3.0"
readme = "README.md"
authors = [
- "Eric Förster <eric.foerster@outlook.com>",
- "Patrick Förster <patrick.foerster@outlook.de>",
+ "Eric Förster <eric.foerster@outlook.com>",
+ "Patrick Förster <patrick.foerster@outlook.de>",
]
edition = "2021"
rust-version = "1.58.1"
@@ -16,14 +16,14 @@ documentation = "https://github.com/latex-lsp/texlab"
keywords = ["lsp", "server", "latex", "bibtex"]
categories = ["development-tools"]
exclude = [
- ".gitattributes",
- ".gitignore",
- ".github/**",
- "tests/it/**",
- "*.snap",
- "texlab.1",
- "texlab.pdf",
- "texlab.tex",
+ ".gitattributes",
+ ".gitignore",
+ ".github/**",
+ "tests/it/**",
+ "*.snap",
+ "texlab.1",
+ "texlab.pdf",
+ "texlab.tex",
]
[[bin]]
@@ -38,14 +38,14 @@ default = ["completion"]
completion = ["fuzzy-matcher"]
[dependencies]
-anyhow = "1.0.57"
+anyhow = "1.0.58"
byteorder = "1.4.3"
chrono = { version = "0.4.19", default-features = false, features = ["std"] }
-clap = { version = "3.1.17", features = [
- "std",
- "derive",
+clap = { version = "3.2.8", features = [
+ "std",
+ "derive",
], default-features = false }
-crossbeam-channel = "0.5.4"
+crossbeam-channel = "0.5.5"
dashmap = "~5.2.0"
derive_more = "0.99.17"
encoding_rs = "0.8.31"
@@ -60,28 +60,28 @@ log = "0.4.17"
logos = "0.12.1"
lsp-server = "0.6.0"
lsp-types = "0.93.0"
-multimap = "0.8.3"
once_cell = "1.10.0"
petgraph = "0.6.2"
regex = "1.5.5"
rowan = "0.15.5"
rustc-hash = "1.1.0"
serde = "1.0.137"
-serde_json = "1.0.81"
+serde_json = "1.0.82"
+serde_regex = "1.1.0"
serde_repr = "0.1.8"
smol_str = { version = "0.1.23", features = ["serde"] }
strum = { version = "0.24.0", features = ["derive"] }
tempfile = "3.3.0"
threadpool = "1.8.1"
-titlecase = "1.1.0"
-unicode-normalization = "0.1.19"
+titlecase = "2.0.0"
+unicode-normalization = "0.1.20"
url = { version = "2.2.2", features = ["serde"] }
uuid = { version = "1.1.2", features = ["v4"] }
[dev-dependencies]
assert_unordered = "0.3.5"
criterion = { version = "0.3.5" }
-insta = { version = "1.14.1", features = ["backtrace", "redactions"] }
+insta = { version = "1.15.0", features = ["backtrace", "redactions"] }
jod-thread = "0.1.2"
[profile.release]