summaryrefslogtreecommitdiff
path: root/support/texlab/Cargo.toml
diff options
context:
space:
mode:
authorNorbert Preining <norbert@preining.info>2022-05-26 03:01:06 +0000
committerNorbert Preining <norbert@preining.info>2022-05-26 03:01:06 +0000
commit02d941fa9c9895bb08a84ac9afe3559abd1ba8ad (patch)
tree481d1d368c6d295a779b590d23bcd5397bcba628 /support/texlab/Cargo.toml
parentf01a37f8311f33e32441d25bdadcda9dcdbd165d (diff)
CTAN sync 202205260301
Diffstat (limited to 'support/texlab/Cargo.toml')
-rw-r--r--support/texlab/Cargo.toml106
1 files changed, 57 insertions, 49 deletions
diff --git a/support/texlab/Cargo.toml b/support/texlab/Cargo.toml
index ad6a333479..df04cfba31 100644
--- a/support/texlab/Cargo.toml
+++ b/support/texlab/Cargo.toml
@@ -1,85 +1,93 @@
[package]
name = "texlab"
description = "LaTeX Language Server"
-version = "3.3.2"
+version = "4.0.0"
license = "GPL-3.0"
readme = "README.md"
authors = [
"Eric Förster <eric.foerster@outlook.com>",
"Patrick Förster <patrick.foerster@outlook.de>",
]
-edition = "2018"
+edition = "2021"
+rust-version = "1.58.1"
homepage = "https://github.com/latex-lsp/texlab"
-resolver = "2"
+repository = "https://github.com/latex-lsp/texlab"
+documentation = "https://github.com/latex-lsp/texlab"
+keywords = ["lsp", "server", "latex", "bibtex"]
+categories = ["development-tools"]
+exclude = [
+ ".gitattributes",
+ ".gitignore",
+ ".github/**",
+ "tests/it/**",
+ "*.snap",
+ "texlab.1",
+ "texlab.pdf",
+ "texlab.tex",
+]
[lib]
doctest = false
[features]
-default = ["citation", "completion"]
+default = ["completion"]
completion = ["fuzzy-matcher"]
-citation = [
- "bibutils-sys",
- "citeproc",
- "citeproc-db",
- "citeproc-io",
- "csl",
- "fnv",
- "html2md",
-]
-semantic = []
[dependencies]
-anyhow = "1.0.54"
-bibutils-sys = { version = "0.1.1", optional = true }
+anyhow = "1.0.57"
byteorder = "1.4.3"
-cancellation = "0.1"
-cfg-if = "1.0.0"
-citeproc = { git = "https://github.com/cormacrelf/citeproc-rs", rev = "2ab195a1e6f84f0ff284813ece61dc62096abbfe", optional = true }
-citeproc-db = { git = "https://github.com/cormacrelf/citeproc-rs", rev = "2ab195a1e6f84f0ff284813ece61dc62096abbfe", optional = true }
-citeproc-io = { git = "https://github.com/cormacrelf/citeproc-rs", rev = "2ab195a1e6f84f0ff284813ece61dc62096abbfe", optional = true }
-csl = { git = "https://github.com/cormacrelf/citeproc-rs", rev = "2ab195a1e6f84f0ff284813ece61dc62096abbfe", optional = true }
-crossbeam-channel = "0.5.2"
-cstree = "0.6.1"
-dashmap = "5.1.0"
+chrono = { version = "0.4.19", default-features = false, features = ["std"] }
+clap = { version = "3.1.17", features = [
+ "std",
+ "derive",
+], default-features = false }
+crossbeam-channel = "0.5.4"
+dashmap = "~5.2.0"
derive_more = "0.99.17"
-encoding_rs = "0.8.30"
+encoding_rs = "0.8.31"
encoding_rs_io = "0.1.7"
-flate2 = "1.0.22"
fern = "0.6"
-fnv = { version = "1.0", optional = true }
+flate2 = "1.0.23"
fuzzy-matcher = { version = "0.3.7", optional = true }
-html2md = { version = "0.2.13", optional = true }
+human_name = { version = "1.0.3", default-features = false }
+isocountry = "0.3.2"
itertools = "0.10.1"
-log = "0.4.14"
+log = "0.4.17"
logos = "0.12.0"
-lsp-server = "0.5"
-lsp-types = "0.92.0"
+lsp-server = "0.6.0"
+lsp-types = "0.93.0"
multimap = "0.8.3"
-notify = "5.0.0-pre.13"
-once_cell = "1.9.0"
+once_cell = "1.10.0"
petgraph = "0.6.0"
-rayon = "1.5.1"
-regex = "1.5.4"
+regex = "1.5.5"
+rowan = "0.15.4"
rustc-hash = "1.1.0"
-serde = "1.0.136"
-serde_json = "1.0.79"
-serde_repr = "0.1.7"
-smol_str = { version = "0.1.21", features = ["serde"] }
-structopt = "0.3"
+serde = "1.0.137"
+serde_json = "1.0.81"
+serde_repr = "0.1.8"
+smol_str = { version = "0.1.23", features = ["serde"] }
+strum = { version = "0.24.0", features = ["derive"] }
tempfile = "3.3.0"
threadpool = "1.8.1"
titlecase = "1.1.0"
-url = "2.2.2"
-uuid = { version = "0.8.2", features = ["v4"] }
+unicode-normalization = "0.1.19"
+url = { version = "2.2.2", features = ["serde"] }
+uuid = { version = "1.0.0", features = ["v4"] }
[dev-dependencies]
-indoc = "1.0.4"
-insta = { version = "1.12.0", features = ["backtrace"] }
+criterion = { version = "0.3.5" }
+indoc = "1.0.6"
+insta = { version = "1.14.0", features = ["backtrace"] }
typed-builder = "0.10.0"
-unindent = "0.1.8"
-
-[build-dependencies]
+unindent = "0.1.9"
[profile.release]
-lto = true
+lto = "fat"
+
+[profile.bench]
+lto = "thin"
+
+[[bench]]
+name = "bench_main"
+path = "benches/bench_main.rs"
+harness = false