summaryrefslogtreecommitdiff
path: root/support/texdepend/Makefile.PL
diff options
context:
space:
mode:
authorNorbert Preining <norbert@preining.info>2019-09-02 13:46:59 +0900
committerNorbert Preining <norbert@preining.info>2019-09-02 13:46:59 +0900
commite0c6872cf40896c7be36b11dcc744620f10adf1d (patch)
tree60335e10d2f4354b0674ec22d7b53f0f8abee672 /support/texdepend/Makefile.PL
Initial commit
Diffstat (limited to 'support/texdepend/Makefile.PL')
-rw-r--r--support/texdepend/Makefile.PL19
1 files changed, 19 insertions, 0 deletions
diff --git a/support/texdepend/Makefile.PL b/support/texdepend/Makefile.PL
new file mode 100644
index 0000000000..1f37ae8893
--- /dev/null
+++ b/support/texdepend/Makefile.PL
@@ -0,0 +1,19 @@
+use ExtUtils::MakeMaker;
+#
+# See lib/ExtUtils/MakeMaker.pm for details of how to influence
+# the contents of the Makefile that is written.
+#
+# As well, if you wish to force a minimal perl version to run the
+# script, insert a line, for example,
+#
+# require 5.004;
+#
+# below.
+
+WriteMakefile(
+ 'NAME' => 'texdepend',
+ 'VERSION_FROM' => 'texdepend', # finds $VERSION
+ 'dist' => { COMPRESS => 'gzip', SUFFIX => 'gz' },
+ 'EXE_FILES' => [ 'texdepend' ], # scripts to install
+);
+