summaryrefslogtreecommitdiff
path: root/support/pkgcheck/Cargo.toml
diff options
context:
space:
mode:
authorNorbert Preining <norbert@preining.info>2019-09-02 13:46:59 +0900
committerNorbert Preining <norbert@preining.info>2019-09-02 13:46:59 +0900
commite0c6872cf40896c7be36b11dcc744620f10adf1d (patch)
tree60335e10d2f4354b0674ec22d7b53f0f8abee672 /support/pkgcheck/Cargo.toml
Initial commit
Diffstat (limited to 'support/pkgcheck/Cargo.toml')
-rw-r--r--support/pkgcheck/Cargo.toml35
1 files changed, 35 insertions, 0 deletions
diff --git a/support/pkgcheck/Cargo.toml b/support/pkgcheck/Cargo.toml
new file mode 100644
index 0000000000..74b14f05cc
--- /dev/null
+++ b/support/pkgcheck/Cargo.toml
@@ -0,0 +1,35 @@
+[package]
+name = "pkgcheck"
+version = "1.8.2"
+authors = ["Manfred Lotz <manfred@ctan.org>"]
+description = "Command-line tool to check packages uploaded to CTAN."
+license = "MIT/Apache-2.0"
+edition = "2018"
+
+[dependencies]
+structopt = "0.2"
+walkdir = "2.2"
+scoped_threadpool = "0.1"
+num_cpus = "1"
+blake2 = "0.8"
+fnv = "1.0.6"
+unbytify = "0.2"
+regex = "1"
+glob = "0.3"
+colored = "1"
+linkify = "0.4"
+reqwest = "0.9"
+lazy_static = "1"
+tempdir = "0.3"
+assert_cmd = "0.11"
+predicates = "1.0"
+openssl-probe = "0.1.2"
+pest = "^2.1"
+pest_derive = "2.1"
+escargot = "0.5"
+
+threadpool = "1.7.1"
+unicode-bom = "1"
+
+
+url = "2.1"