summaryrefslogtreecommitdiff
path: root/support/pkgcheck/Cargo.toml
diff options
context:
space:
mode:
authorNorbert Preining <norbert@preining.info>2020-11-30 03:00:37 +0000
committerNorbert Preining <norbert@preining.info>2020-11-30 03:00:37 +0000
commitcb68d38823870fa7adb5f0c2b68cf59205dd4bec (patch)
tree8d6e29ee5d082dcbf1ad936b7025db071e9cf573 /support/pkgcheck/Cargo.toml
parent0cc87411bcebcb1b0d2a3488d7a7093024b58650 (diff)
CTAN sync 202011300300
Diffstat (limited to 'support/pkgcheck/Cargo.toml')
-rw-r--r--support/pkgcheck/Cargo.toml11
1 files changed, 6 insertions, 5 deletions
diff --git a/support/pkgcheck/Cargo.toml b/support/pkgcheck/Cargo.toml
index 39fe8901b5..870304d75c 100644
--- a/support/pkgcheck/Cargo.toml
+++ b/support/pkgcheck/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "pkgcheck"
-version = "2.1.0"
+version = "2.2.0"
authors = ["Manfred Lotz <manfred@ctan.org>"]
description = "Command-line tool to check packages uploaded to CTAN."
license = "MIT/Apache-2.0"
@@ -10,24 +10,25 @@ edition = "2018"
# https://doc.rust-lang.org/edition-guide/rust-2018/error-handling-and-panics/aborting-on-panic.html
[profile.release]
panic = "abort"
+lto = true
[dependencies]
structopt = "0.3"
walkdir = "2.3"
scoped_threadpool = "0.1"
num_cpus = "1"
-blake2 = "0.8"
+blake2 = "0.9"
fnv = "1.0.6"
unbytify = "0.2"
regex = "1"
glob = "0.3"
-colored = "1"
+colored = "2"
linkify = "0.4"
reqwest = { version = "0.10", features = ["blocking", "gzip"] }
lazy_static = "1"
-tempdir = "0.3"
+tempfile = "3.1"
assert_cmd = "1"
predicates = "1"
openssl-probe = "0.1.2"
@@ -35,7 +36,7 @@ pest = "2.1"
pest_derive = "2.1"
escargot = "0.5"
-threadpool = "1.7.1"
+threadpool = "1.8"
unicode-bom = "1"
url = "2.1"