summaryrefslogtreecommitdiff
path: root/support/pkgcheck/Cargo.toml
diff options
context:
space:
mode:
authorNorbert Preining <norbert@preining.info>2022-01-16 03:01:19 +0000
committerNorbert Preining <norbert@preining.info>2022-01-16 03:01:19 +0000
commita574e957682cad50981ddb567c2a106213dc8672 (patch)
treecd02ecf7773fd7bad8e7b6cdb07cf2ff437ba59f /support/pkgcheck/Cargo.toml
parent0cb730e5737ffa35f797eaf75c2613e5ac88617c (diff)
CTAN sync 202201160301
Diffstat (limited to 'support/pkgcheck/Cargo.toml')
-rw-r--r--support/pkgcheck/Cargo.toml39
1 files changed, 35 insertions, 4 deletions
diff --git a/support/pkgcheck/Cargo.toml b/support/pkgcheck/Cargo.toml
index fa6fcc58ae..29048feda9 100644
--- a/support/pkgcheck/Cargo.toml
+++ b/support/pkgcheck/Cargo.toml
@@ -1,10 +1,11 @@
[package]
name = "pkgcheck"
-version = "2.3.0"
+version = "2.4.0"
authors = ["Manfred Lotz <manfred@ctan.org>"]
description = "Command-line tool to check packages uploaded to CTAN."
license = "MIT/Apache-2.0"
-edition = "2018"
+readme = "README.md"
+edition = "2021"
# with this option binaries are smaller
# https://doc.rust-lang.org/edition-guide/rust-2018/error-handling-and-panics/aborting-on-panic.html
@@ -17,13 +18,13 @@ structopt = "0.3"
walkdir = "2.3"
scoped_threadpool = "0.1"
num_cpus = "1"
-blake2 = "0.9"
+blake3 = "1.2.0"
rustc-hash = "1.1"
unbytify = "0.2"
regex = "1"
glob = "0.3"
colored = "2"
-linkify = "0.7"
+linkify = "0.8"
reqwest = { version = "0.11", features = ["blocking", "gzip"] }
tokio = { version = "1", features = ["full"] }
@@ -42,3 +43,33 @@ unicode-bom = "1"
url = "2.1"
+zip = { version = "0.5", default-features = false }
+zip-extensions = "0.6"
+
+[package.metadata.deb]
+section = "utility"
+depends = ""
+priority = "optional"
+assets = [
+ ["target/x86_64-unknown-linux-musl/release/pkgcheck", "usr/bin/", "755"],
+ ["LICENSE-MIT", "usr/share/doc/pkgcheck/", "644"],
+ ["LICENSE-APACHE", "usr/share/doc/pkgcheck/", "644"],
+ ["README.md", "usr/share/doc/pkgcheck/README", "644"],
+ ["docs/pkgcheck.pdf", "usr/share/doc/pkgcheck/pkgcheck.pdf", "644"],
+]
+extended-description = """\
+A checker for uploaded packages to CTAN
+"""
+
+changelog = "CHANGES.md"
+
+
+
+[package.metadata.rpm]
+package = "pkgcheck"
+
+[package.metadata.rpm.cargo]
+buildflags = ["--release"]
+
+[package.metadata.rpm.targets]
+pkgcheck = { path = "/usr/bin/pkgcheck" }