summaryrefslogtreecommitdiff
path: root/support/pkgcheck/Cargo.toml
diff options
context:
space:
mode:
authorNorbert Preining <norbert@preining.info>2022-05-27 03:01:31 +0000
committerNorbert Preining <norbert@preining.info>2022-05-27 03:01:31 +0000
commit84a5593d3fb9d03aac5677678bcc4c92e8c9a9c4 (patch)
tree0212ba38147bcfe80e5c1a853071a6e6a45b87d7 /support/pkgcheck/Cargo.toml
parent02d941fa9c9895bb08a84ac9afe3559abd1ba8ad (diff)
CTAN sync 202205270301
Diffstat (limited to 'support/pkgcheck/Cargo.toml')
-rw-r--r--support/pkgcheck/Cargo.toml53
1 files changed, 30 insertions, 23 deletions
diff --git a/support/pkgcheck/Cargo.toml b/support/pkgcheck/Cargo.toml
index 29048feda9..f7120709d4 100644
--- a/support/pkgcheck/Cargo.toml
+++ b/support/pkgcheck/Cargo.toml
@@ -1,12 +1,15 @@
[package]
name = "pkgcheck"
-version = "2.4.0"
+version = "3.0.0"
authors = ["Manfred Lotz <manfred@ctan.org>"]
description = "Command-line tool to check packages uploaded to CTAN."
license = "MIT/Apache-2.0"
readme = "README.md"
edition = "2021"
+[[bin]]
+name = "pkgcheck"
+
# with this option binaries are smaller
# https://doc.rust-lang.org/edition-guide/rust-2018/error-handling-and-panics/aborting-on-panic.html
[profile.release]
@@ -14,37 +17,41 @@ panic = "abort"
lto = true
[dependencies]
-structopt = "0.3"
-walkdir = "2.3"
-scoped_threadpool = "0.1"
-num_cpus = "1"
-blake3 = "1.2.0"
-rustc-hash = "1.1"
-unbytify = "0.2"
-regex = "1"
-glob = "0.3"
+blake3 = "1.3"
+clap = { version = "3.1.6", features = ["derive"] }
+clap_complete = "3.1.1"
colored = "2"
+config = "0.13"
+escargot = "0.5"
+fern = "0.6"
+glob = "0.3"
+home = "0.5.3"
+once_cell = "1.10.0"
+#lazy_static = "1"
linkify = "0.8"
-
-reqwest = { version = "0.11", features = ["blocking", "gzip"] }
-tokio = { version = "1", features = ["full"] }
-
-lazy_static = "1"
-tempfile = "3.1"
-assert_cmd = "2"
-predicates = "2"
+log = "0.4"
+num_cpus = "1"
openssl-probe = "0.1.4"
pest = "2.1"
pest_derive = "2.1"
-escargot = "0.5"
-
+regex = "1"
+reqwest = { version = "0.11", features = ["blocking", "gzip"] }
+rustc-hash = "1.1"
+scoped_threadpool = "0.1"
+serde = { version = "1.0", features = ["derive"] }
+serde_yaml = "0.8"
+tempfile = "3.1"
threadpool = "1.8"
+tokio = { version = "1", features = ["full"] }
+unbytify = "0.2"
unicode-bom = "1"
-
url = "2.1"
+walkdir = "2.3"
+zip = { version = "^0.6", default-features = false, features = ["deflate"] }
-zip = { version = "0.5", default-features = false }
-zip-extensions = "0.6"
+[dev-dependencies]
+assert_cmd = "2"
+predicates = "2"
[package.metadata.deb]
section = "utility"