summaryrefslogtreecommitdiff
path: root/support/lacheck/Makefile.am
diff options
context:
space:
mode:
authorNorbert Preining <norbert@preining.info>2019-09-02 13:46:59 +0900
committerNorbert Preining <norbert@preining.info>2019-09-02 13:46:59 +0900
commite0c6872cf40896c7be36b11dcc744620f10adf1d (patch)
tree60335e10d2f4354b0674ec22d7b53f0f8abee672 /support/lacheck/Makefile.am
Initial commit
Diffstat (limited to 'support/lacheck/Makefile.am')
-rw-r--r--support/lacheck/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/support/lacheck/Makefile.am b/support/lacheck/Makefile.am
new file mode 100644
index 0000000000..7a39cbbf55
--- /dev/null
+++ b/support/lacheck/Makefile.am
@@ -0,0 +1,26 @@
+## $Id: Makefile.am 51585 2019-07-08 22:23:38Z karl $
+## Makefile.am for the TeX Live subdirectory utils/lacheck/
+##
+## Copyright 2015-2019 Karl Berry <tex-live@tug.org>
+## Copyright 2009-2015 Peter Breitenlohner <tex-live@tug.org>
+## You may freely use, modify and/or distribute this file.
+
+AM_CFLAGS = $(WARNING_CFLAGS)
+
+bin_PROGRAMS = lacheck
+
+lacheck_SOURCES = lacheck.l
+
+## Manpage
+nodist_man1_MANS = lacheck.1
+
+## Test
+TESTS = lacheck.test test-def.test
+dist_check_SCRIPTS = $(TESTS)
+lacheck.log: lacheck$(EXEEXT)
+EXTRA_DIST = test.old test.tex test-def.tex test-def.xout
+CLEANFILES = test.out test-def.out
+
+## Not used
+EXTRA_DIST += lacheck.hlp make_vms.com
+