summaryrefslogtreecommitdiff
path: root/support/dktools/dktools-fedora.spec
diff options
context:
space:
mode:
authorNorbert Preining <norbert@preining.info>2019-09-02 13:46:59 +0900
committerNorbert Preining <norbert@preining.info>2019-09-02 13:46:59 +0900
commite0c6872cf40896c7be36b11dcc744620f10adf1d (patch)
tree60335e10d2f4354b0674ec22d7b53f0f8abee672 /support/dktools/dktools-fedora.spec
Initial commit
Diffstat (limited to 'support/dktools/dktools-fedora.spec')
-rw-r--r--support/dktools/dktools-fedora.spec673
1 files changed, 673 insertions, 0 deletions
diff --git a/support/dktools/dktools-fedora.spec b/support/dktools/dktools-fedora.spec
new file mode 100644
index 0000000000..4ba218a0e2
--- /dev/null
+++ b/support/dktools/dktools-fedora.spec
@@ -0,0 +1,673 @@
+#
+# If you think the *.spec files need corrections, please send me a
+# complete working *.spec file, not just a bug report.
+# I moved my laptop from Scientific Linux to Debian (they still
+# provide a 32 bit version with recent software), so I do no longer
+# have access to machines I could use to test *.spec files.
+#
+Name: dktools
+Version: 4.8.3
+Source: file:///home/krause/work/dktools-4.8.3.tar.gz
+Release: 1%{?dist}
+Summary: Dirk Krause's tools and libraries
+Vendor: Dirk Krause
+# Packager: Dirk Krause
+Group: Applications/System
+License: BSD
+URL: http://dktools.sourceforge.net/index.html
+BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
+
+BuildRequires: community-mysql-devel zlib-devel bzip2-devel libpng-devel openssl-devel libjpeg-devel libtiff-devel net-snmp-devel wxGTK wxGTK-devel
+Requires: zlib bzip2 openssl mysql-libs libpng libjpeg libtiff net-snmp wxGTK
+Conflicts: dktools-rescue
+Prefix: %{_prefix}
+
+# ___PROVIDES___
+
+%description
+A set of tools for graphics conversion, text conversion, software
+development, administration and printing and some general-purpose tools.
+ bmpp / wxbmpp Convert PNG/JPEG/TIFF to PS/EPS/PDF
+ fig2lat Convert FIG to PGF,EPS+TeX,PDF+TeX,EPS,SVG
+ wximgsz Suggest good sizes to rescale bitmap images
+ htmlbook Publish HTML like a book
+ dkct / wxdkct Preprocessor for C, C++, Objective-C and Java
+ (debugging/tracing, state machines, wxWidgets GUIs)
+ dkwxwiz Create project skeleton for wxWidgets+dktools based programs
+ wxdkhtb Viewer for *.htb help files
+ itadmin Use a MySQL database to manage your IT
+ dk-ls ls clone, configurable column order
+ dk-fic File integrity checker
+ dk-bmm Backup media manager (10 tape rotation)
+ dk-blks Correct data stream blocksize (for use with dd)
+ dk-eradisk Create data stream to erase a disk
+ dk-hex Show data in hexadecimal or octal notation
+ dk-cat cat clone, recoding between ASCII/UTF-8/UTF-16
+ dk-sort sort clone, processes ASCII/UTF-8/UTF-16
+ dk-t2h Text to HTML converter
+ dk-t2l Text to LaTeX converter
+ dk-sqlsplit Split overlong SQL lines from mysqldump
+ dk-uid Find user ID in given range
+ dk-pwgen Create passwords, PINs and WiFi keys
+ dk-send Send data stream to one or multiple recipients over TCP
+ dk-recv Receive data stream from a dk-send process
+ dkdbt Tool for simple databases
+ printqd Print quota enforcement for LPRng print systems
+ wxpqdic GUI client to check print quota
+ addctrld Add CTRL-D to end of data stream if not yet present
+ wxdkclock Simple clock, one alert
+ plpdftex Output driver for octpgfpl
+
+%prep
+%setup -q
+# %setup
+
+
+%build
+%configure --enable-packaging
+make %{?_smp_mflags}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+make install DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+
+%files
+%defattr(-,root,root,-)
+%doc README bsdlic.txt
+%{_bindir}/*
+%{_libdir}/libdk3*.so.*
+%{_libdir}/libdk4*.so.*
+%{_datadir}/applications/*
+%{_datadir}/dktools
+%{_datadir}/dk4app
+%{_datadir}/man/man1/*
+%{_datadir}/man/man5/*
+%{_sysconfdir}/printqd/printqd.conf.sample
+%{_sysconfdir}/rshdown/rshdown.conf.sample
+%config %{_sysconfdir}/dk3app/dk3paper.conf
+
+%post
+# ##### ATTEMPT TO GUESS USER AND GROUP FOR LPRng LPD DAEMON
+#
+LPUSER=`getent passwd | grep '^daemon:' | cut -f 1 -d :`
+if [ "X$LPUSER" = "X" ]
+then
+ LPUSER=`getent passwd | grep '^lp:' | cut -f 1 -d :`
+fi
+if [ "X$LPUSER" = "X" ]
+then
+ LPUSER="root"
+fi
+LPGROUP=`getent group | grep '^daemon:' | cut -f 1 -d :`
+if [ "X$LPGROUP" = "X" ]
+then
+ LPGROUP=`getent group | grep '^lp:' | cut -f 1 -d :`
+fi
+if [ "X$LPGROUP" = "X" ]
+then
+ LPGROUP="root"
+fi
+#
+# #####
+#
+#
+#
+# ##### LINUX DISTRIBUTION PACKAGERS
+# ##### If your distribution contains the LPRng software, please
+# ##### uncomment the two lines below and set LPUSER and LPGROUP to
+# ##### the user and group used to run the LPRng lpd daemon on
+# ##### your distribution.
+# ##### Optionally remove the lines above attempting to guess these names.
+#
+# LPUSER="daemon"
+# LPGROUP="daemon"
+#
+# #####
+for i in /var/printqd /var/log/printqd /var/run/printqd
+do
+ [ -d $i ] || mkdir -p $i
+ chown -R ${LPUSER}:${LPGROUP} $i
+ chmod 770 $i
+done
+ldconfig
+
+%postun
+if [ "X$1" = "X0" ]
+then
+ [ ! -d /var/run/printqd ] || rm -fr /var/run/printqd
+ [ ! -d /var/log/printqd ] || rm -fr /var/log/printqd
+fi
+ldconfig
+
+
+
+#
+# The rescue sub-package installs only those binaries useful on
+# a rescue live system.
+#
+%package rescue
+#
+# The devel sub-package installs developer support.
+#
+Summary: Only those DK tools binaries useful on a rescue live system
+Group: Applications/System
+Requires: zlib bzip2 openssl
+Conflicts: dktools
+Prefix: %{_prefix}
+
+%description rescue
+On live systems for system rescue we only need the dknet and dkt program.
+
+%files rescue
+%defattr(-,root,root,-)
+%doc README bsdlic.txt
+%{_bindir}/dk-send
+%{_bindir}/dk-recv
+%{_bindir}/dk-blks
+%{_bindir}/dk-cat
+%{_bindir}/dk-eradisk
+%{_bindir}/dk-ls
+%{_libdir}/libdk4socka.so.*
+%{_libdir}/libdk4sock.so.*
+%{_libdir}/libdk4maiodh.so.*
+%{_libdir}/libdk4maio8h.so.*
+%{_libdir}/libdk4app.so.*
+%{_libdir}/libdk4c.so.*
+%{_libdir}/libdk4maiodd.so.*
+%{_libdir}/libdk4maiowd.so.*
+%{_libdir}/libdk4maio8d.so.*
+%{_libdir}/libdk4base.so.*
+%{_datadir}/dktools/en/dk-send.*
+%{_datadir}/dktools/en/dk-recv.*
+%{_datadir}/dktools/en/dk-cat.*
+%{_datadir}/dktools/en/dk-blks.*
+%{_datadir}/dktools/en/dk-ls.*
+%{_datadir}/dktools/de/dk-send.*
+%{_datadir}/dktools/de/dk-recv.*
+%{_datadir}/dktools/de/dk-cat.*
+%{_datadir}/dktools/de/dk-blks.*
+%{_datadir}/dktools/de/dk-ls.*
+
+
+%post rescue
+ldconfig
+
+%postun rescue
+ldconfig
+
+
+
+
+
+%package devel
+Summary: Development files for libraries from the DK tools project
+Group: Development/Libraries
+Requires: dktools = %{version}-%{release} community-mysql-devel zlib-devel bzip2-devel libpng-devel openssl-devel libjpeg-devel libtiff-devel net-snmp-devel gcc wxGTK wxGTK-devel
+Prefix: %{_prefix}
+
+%description devel
+If you want to use modules from the DK tools project in your programs,
+you need the libraries from the dktools-lib package and the header
+files provided by this project.
+
+%files devel
+%defattr(-,root,root,-)
+%{_includedir}/*
+%{_libdir}/pkgconfig/dktools.pc
+%{_libdir}/libdk3*.so
+%{_libdir}/libdk4*.so
+
+%changelog
+
+* Tue Mar 28 2017 Dirk Krause <krause.dirk@web.de> 4.8.3-0.0.1
+- Followed improvement suggestions from the CTAN team.
+
+* Fri Mar 24 2017 Dirk Krause <krause.dirk@web.de> 4.8.2-0.0.1
+- Modified bmpp to write a /CropBox in addition to /MediaBox in PDF output.
+
+* Wed Mar 22 2017 Dirk Krause <krause.dirk@web.de> 4.8.1-0.0.1
+- Modified dk-send to stop reading input if all clients disconnected
+ unexpectedly.
+
+* Sun Mar 19 2017 Dirk Krause <krause.dirk@web.de> 4.8.0-0.0.1
+- Library libdk4maioxd added (wxChar numbers input and output).
+- Package lshw added to package list for DKtoolian.
+- Configure script and Makefile.in modified to have less warnings from
+ Debian package building.
+
+* Fri Feb 03 2017 Dirk Krause <krause.dirk@web.de> 4.7.0-0.0.1
+- "xxxx" can be used as copyright end year in the "copyright year"
+ setting in options sections of *.ctr, *.wxc and *.cpt files.
+- New modules dk4paper and dk4papea to read papersizes configuration
+ files.
+
+* Sun Dec 11 2016 Dirk Krause <krause.dirk@web.de> 4.6.0-0.0.1
+- New functions in dk4memrs, dk4str8, dk4strw and dk4str to sanitize
+ buffers and strings.
+
+* Thu Oct 27 2016 Dirk Krause <krause.dirk@web.de> 4.5.0-0.0.1
+- Added support for meta/description and meta/keywords tags to htmlbook.
+- New modules for arithmetic operations on int16_t, uint16_t, int32_t, uint32_t.
+- New modules to serialize data to stream, unserialize from stream.
+- New module for compressed/encoded output on a dk4_stream_t.
+
+* Wed Sep 07 2016 Dirk Krause <krause.dirk@web.de> 4.4.0-0.0.1
+- Configuration option for itadmin to release lease on shutdown.
+- Markers in dhcpd.conf produced by itadmin for easier post-processing.
+- New module dk4strmw to open a file stream for writing.
+- New module dk4fpe to check for floating point exceptions.
+- New modules to read double from string and write double to string.
+- Mathematical operations on int16_t, int32_t, uint16_t and uint32_t
+ including error checking.
+- Inline functions or macros to copy, reset and compare memory buffers.
+- Modules dk4mai8dbl, dk4maiddbl, dk4maiwdbl, dk4mao8dbl, dk4maoddbl
+ and dk4maowdbl to read double from string and write double to string.
+- API change in dk4stream_write(): the buffer argument is const now.
+- Optimization in dk4stream_write().
+- Bugfixes in GUI applications: No wxXXX objects must survive OnExit().
+- Bugfixes in the dk4strw module.
+- Bugfixes in checking for mysql.h file.
+- Code cleanup in DkWxBmepsApp.cpt, DkWxImgszApp.cpt and DkWxTraceApp.cpt
+ to improve readability.
+
+* Tue Jul 12 2016 Dirk Krause <krause.dirk@web.de> 4.3.6-0.0.1
+- Bugfix for Windows (try multiple sources to get home directory).
+- Replacements for GetVersionEx() function in Windows.
+- Docu update for installation using stow.
+
+* Sat Jul 02 2016 Dirk Krause <krause.dirk@web.de> 4.3.5-0.0.1
+- New hint special command for htmlbook.
+- Scripts to produce live systems.
+
+* Fri Jun 10 2016 Dirk Krause <krause.dirk@web.de> 4.3.4-0.0.1
+- Added span.hint to style.css for htmlbook.
+- Smaller changes related to Debian packaging.
+
+* Sat May 28 2016 Dirk Krause <krause.dirk@web.de> 4.3.3-0.0.1
+- Debian packaging changed, developer package is dktools-lib-$(4.8)-dev.
+- RPM packaging changed, shared library symlinks now in devel package.
+- New script to generate debian/changelog from dktools-el6.spec.in file.
+
+* Fri May 27 2016 Dirk Krause <krause.dirk@web.de> 4.3.2-0.0.1
+- New special command "htmlname" in htmlbook program.
+- Directory structure in build process changed due to lintian complaints.
+- Bugfix in dktools.pc, Libs.private now set correctly.
+- Script itaclean.sh renamed to itaclean (due to lintian complaints).
+
+* Mon Apr 25 2016 Dirk Krause <krause.dirk@web.de> 4.3.1-0.0.1
+- Printqdc now accepts empty input lines.
+
+* Tue Apr 19 2016 Dirk Krause <krause.dirk@web.de> 4.3.0-0.0.1
+- Printqd and related programs rewritten completely.
+- Rshdown is back on a users request, ported to library version 4.
+- Print order character 'N' added to dk-ls (do not show symlink target).
+- Option -b for dk-pwgen on non-Windows systems (create binary random data).
+- New program dk-rand to generate binary random data.
+- Modifications to dk4_app_t and dk3_app_t modules: create log and tmp
+ directories only when needed.
+- Modified dk4inst.h header: Compiler constant texts for directories.
+- Module dk4dmt added, tool functions for standing daemons.
+- Modified dk4sock13 module, delete existing UNIX domain sockets.
+- Modified DkWxFrame and Dk4WxFrame, restore position when frame is shown.
+- Bugfix in dkwxwiz data files, typo corrected.
+- Bugfix in dk4dbi module, must set ulen, not size when retrieving data.
+- Retired dk3sock module, all networking programs use library version 4 now.
+
+* Fri Jan 22 2016 Dirk Krause <krause.dirk@web.de> 4.2.2-0.0.1
+- Modified dk-cat, dk-hex, dk-pwgen, dk-t2h, dk-t2l, dk-db2t:
+ No error message for SIGPIPE received.
+- Some modifications following suggestions from clang static code analysis.
+
+* Tue Jan 19 2016 Dirk Krause <krause.dirk@web.de> 4.2.1-0.0.1
+- Modifications in Makefile.in and scripts/dkmkproto.pl for SVR4 packaging.
+
+* Mon Jan 18 2016 Dirk Krause <krause.dirk@web.de> 4.2.0-0.0.1
+- Performance fix for dk-send/dk-recv: Use larger buffers.
+- Performance fix for dk-ls: Avoid unnecessary size calculations.
+- Programs dk-t2db, dk-db2t and dk-dbco to replace dkdbt.
+- Libraries dk4dbia and dk4dbi added to replace dk3dbi.
+- Bugfix in dk4loc module, set encoding even if no LANG variable available.
+
+* Mon Dec 14 2015 Dirk Krause <krause.dirk@web.de> 4.1.0-0.0.1
+- Added -s option to dk-ls, show summary at end.
+- Manpage installation avoided, when building on Debian
+ (manpage installation on Debian is done by package management).
+- New functions to retrieve and expand strings from Windows registry.
+- Changes in makefiles for Visual Studio for Desktop on Windows.
+- Bugfix in dk4user module: Must expand user profile string from registry.
+- Bugfix in DkClockFrame.wxc: Minimum size specified.
+- Bugfix in DkWxImgszFrame.wxc: Format specifier corrected.
+- Bugfix in DkWxImgszApp.cpt: Load all image handlers wxInitAllImageHandlers()
+
+* Fri Dec 04 2015 Dirk Krause <krause.dirk@web.de> 4.0.10-0.0.1
+- Man pages added, required for Debian packaging.
+- Build process on Windows can now use different library directories.
+- Bugfix in dkdbt program: No longer error messages for comment lines.
+- First release after changing Linux distribution to Debian on my laptop.
+
+* Tue Nov 10 2015 Dirk Krause <krause.dirk@web.de> 4.0.9-0.0.1
+- Bugfix in Makefile.in: Some programs were mentioned twice.
+
+* Sun Nov 08 2015 Dirk Krause <krause.dirk@web.de> 4.0.8-0.0.1
+- Number of duplicated files in source archive reduced by use of hard links.
+
+* Fri Oct 16 2015 Dirk Krause <krause.dirk@web.de> 4.0.7-0.0.1
+- Bugfix in dk4loc module: Use "en" as default language.
+- Bugfix in configure.ac: Install shared libraries for rescue systems too.
+
+* Sat Oct 10 2015 Dirk Krause <krause.dirk@web.de> 4.0.6-0.0.1
+- Added -t option to dk-sort.
+- Only one AC_OUTPUT line in Makefile.in.
+
+* Tue Oct 06 2015 Dirk Krause <krause.dirk@web.de> 4.0.5-0.0.1
+- Help text for dk-recv corrected, host and port are mandatory.
+- Compiler flags for wxcs added in Makefile.in.
+- Removed some dead assignments after static analysis.
+
+* Wed Sep 23 2015 Dirk Krause <krause.dirk@web.de> 4.0.4-0.0.1
+- Makefile.in: Use C++ compiler to drive linker if any C++ module in project.
+- Makefile.in: libdk4wx.a in the LIB_ST_GUI group, not LIB_ST_CLI.
+- dktools.pc.in: Correct variable for version number used now.
+- dk3strkv/dk-sqlsplit: S_ERROR replaced by ST_ERROR.
+- configure.ac: No -Bdynamic -dy -KPIC -D_REENTRANT for static builds.
+- configure.ac: Option --with-corrections for some Solaris systems.
+
+* Tue Aug 11 2015 Dirk Krause <krause.dirk@web.de> 4.0.3-0.0.1
+- Module dk3uc2l rewritten to use the *.t2l files.
+
+* Tue Aug 04 2015 Dirk Krause <krause.dirk@web.de> 4.0.2-0.0.1
+- Setting for tooltip flag added to dkct.
+
+* Tue Aug 04 2015 Dirk Krause <krause.dirk@web.de> 4.0.1-0.0.1
+- dkct: Special placeholders in $? format string.
+- dkct: Option -p added for portable debug output code.
+
+* Tue Aug 04 2015 Dirk Krause <krause.dirk@web.de> 4.0.0-0.0.1
+- New rewritten library modules dk4*.
+- Simplified error reporting from callee to caller via dk4_er_t structure.
+- Reduced use of runtime library on Windows systems.
+- Text stream processing functions recognize BOM at start of data.
+- Multiple dk4sock* modules instead of one large module.
+- wxdkfcs: GUI program to inspect file checksums.
+- dkt: Replaced by multiple smaller programs.
+- dkct: Cell contents for wxGrid in wx gui section.
+
+* Thu Jul 09 2015 Dirk Krause <krause.dirk@web.de> 3.18.10-0.0.1
+- dk-tape: Code simplified.
+
+* Thu Apr 02 2015 Dirk Krause <krause.dirk@web.de> 3.18.9-0.0.1
+- Modified configure script and Makefile for --enable-packaging option.
+
+* Fri Mar 13 2015 Dirk Krause <krause.dirk@web.de> 3.18.8-0.0.1
+- Modified configure script and Makefile.
+
+* Sat Feb 21 2015 Dirk Krause <krause.dirk@web.de> 3.18.7-0.0.1
+- dkct: Bugfix, doxygen allows pure @file lines.
+
+* Wed Jan 28 2015 Dirk Krause <krause.dirk@web.de> 3.18.6-0.0.1
+- Bugfix in plpdftex: smash used only for texts aligned by base line.
+
+* Thu Jan 22 2015 Dirk Krause <krause.dirk@web.de> 3.18.5-0.0.1
+- Bugfix in dkt tape: wrong number printed.
+- Bugfix in plpdftex: smash not for texts in boxes.
+- Modified pjsnmp: Added pjsnmpreadystates configuration option
+- Modified pjsnmp: Message texts modified, distinction errors/warnings.
+
+* Mon Dec 08 2014 Dirk Krause <krause.dirk@web.de> 3.18.4-0.0.1
+- Bugfix in plpdftex: sometimes invalid *.tex output.
+
+* Mon Dec 01 2014 Dirk Krause <krause.dirk@web.de> 3.18.3-0.0.1
+- Bugfix in UTF-16 encoding: Surrogate range was wrong.
+
+* Wed Nov 26 2014 Dirk Krause <krause.dirk@web.de> 3.18.2-0.0.1
+- Modified dkct: No @file line added if @file line is already present.
+- Data type dk3_c32_t changed to unsigned if unsigned is 4 bytes long.
+- Check whether password memory really was reset.
+
+* Tue Oct 21 2014 Dirk Krause <krause.dirk@web.de> 3.18.1-0.0.1
+- Bugfix in multiplication overflow detection in dk3mas/dk3mai/dk3mal modules.
+
+* Thu Oct 16 2014 Dirk Krause <krause.dirk@web.de> 3.18.0-0.0.1
+- Copyright year check in dkct.
+- API bugfix in dk3str32/dk3str16: Use correct character size now.
+- Bugfix in htmlbook for using dkChar.
+- Bugfix in dkdbt for using dkChar.
+- Splitted dk3mastr module into several modules.
+- Most uses of sscanf() and dk3sf_sscanf3() replaced by other functions.
+
+* Wed Sep 24 2014 Dirk Krause <krause.dirk@web.de> 3.17.2-0.0.1
+- Bugfix in dk3sock: WSAEWOULDBLOCK is used for connect in progress.
+
+* Fri Sep 12 2014 Dirk Krause <krause.dirk@web.de> 3.17.1-0.0.1
+- Bugfix in archive creation: Permissions are correct now.
+
+* Wed Sep 03 2014 Dirk Krause <krause.dirk@web.de> 3.17.0-0.0.1
+- Appendices k, M, G for block size added for dkt blks/ dkt ed/dkt rnd.
+- Bugfix in fig2lat: EPS/PDF/PGF output driver, corner radius.
+- Bugfix in wxbmpp dk3paper module.
+- Bugfix in wxbmpp: Fitting to a paper size.
+
+* Thu Aug 07 2014 Dirk Krause <krause.dirk@web.de> 3.16.3-0.0.1
+- Changed build process for Linux/Unix.
+
+* Tue Aug 05 2014 Dirk Krause <krause.dirk@web.de> 3.16.2-0.0.1
+- Changed build process for Linux/Unix, removed options from configure.
+
+* Tue Aug 05 2014 Dirk Krause <krause.dirk@web.de> 3.16.1-0.0.1
+- Use wxFD_OPEN instead of wxOPEN.
+- Bugfix in makefile: CLFAGS was a typo.
+
+* Mon Jul 28 2014 Dirk Krause <krause.dirk@web.de> 3.16.0-0.0.1
+- New program plpdftex added, output driver for octpgfpl.
+- Prefer sigaction() over sigset().
+- Function-like macros replaced by functions.
+- Modified overflow check for conversion from unsigned long to size_t.
+- Modified dk3ma module: Splitted into several smaller modules.
+- Functions dk3strm_double_c8_no_sci()... added.
+- Function dk3pdf_write_double() treats small numbers as 0.
+
+* Sat Jun 28 2014 Dirk Krause <krause.dirk@web.de> 3.15.0-0.0.1
+- Source code reorganized.
+
+* Thu Jun 19 2014 Dirk Krause <krause.dirk@web.de> 3.14.0-0.0.1
+- Options -S... added to dkct and wxdkct.
+- Memory usage reorganized for bit matrices.
+- Cache friendly algorithm for bit matrix expansion.
+- dktools.spec file modified to build sub-packages lib and devel.
+
+* Tue May 27 2014 Dirk Krause <krause.dirk@web.de> 3.13.0-0.0.1
+- Modified htmlbook: Line numbering for source code.
+- Modified dkt html: Line numbering for source code.
+- Added *.desktop files for GUI programs.
+
+* Wed Apr 30 2014 Dirk Krause <krause.dirk@web.de> 3.12.0-0.0.1
+- New application wxdkhtb added to view help text files.
+- Modified htmlbook: enable/disable full text search in *.chm output.
+- Installation bugfix: Forgot to install libdk3wx.so.
+- HTML files for online help now created by htmlbook.
+- API change in DkWxFrame class: Methods added.
+
+* Wed Apr 23 2014 Dirk Krause <krause.dirk@web.de> 3.11.0-0.0.1
+- htmlbook: Writing project.xml file.
+- htmlbook: New option chm full text search.
+- htmlbook: Section number optional before section title in index and pos.
+- htmlbook: Titles for links in keyword index.
+- htmlbook: Bugfix, all *.html files listed in files section.
+- htmlbook: Bugfix, added missing closing OBJECT tag.
+- htmlbook: Bugfix, copy index.hhp, index.hhc and index.hhk to destination.
+- htmlbook: Bugfix, root object now in TOC as first object.
+- printqd: Attempt to remove existing local socket before creating new one.
+- printqd: Bugfix, endless loop.
+- wxdkclock: Save changed options immediately.
+
+* Mon Mar 31 2014 Dirk Krause <krause.dirk@web.de> 3.10.0-0.0.1
+- Modified fig2lat: Fast splines for arrowheads.
+- Modified fig2lat: Configurable base line width.
+
+* Mon Mar 24 2014 Dirk Krause <krause.dirk@web.de> 3.9.0-0.0.1
+- Bugfix in bmpp/wxbmpp: Bits per component analysis rewritten.
+
+* Sun Mar 02 2014 Dirk Krause <krause.dirk@web.de> 3.8.3-0.0.1
+- Bugfix bmpp/wxbmpp: Automatic bits per component analysis disabled.
+- Modified htmlbook: New classes for table cells added to style.css file.
+
+* Thu Feb 06 2014 Dirk Krause <krause.dirk@web.de> 3.8.2-0.0.1
+- Modified htmlbook: New no-vspace option for img special command.
+- Modified htmlbook: Shortcuts for images.
+
+* Wed Jan 29 2014 Dirk Krause <krause.dirk@web.de> 3.8.1.0.0.1
+- Modified htmlbook: Set permissions for destination directory contents.
+- Modified htmlbook: Change in style.css, added top and bottom margin.
+- Bugfix in htmlbook: Crashes on filenames without suffix.
+
+* Tue Jan 21 2014 Dirk Krause <krause.dirk@web.de> 3.8.0-0.0.1
+- New application htmlbook added.
+- Bugfix in dk3enc module: Wrong range delimiter for Unicode characters.
+
+* Fri Nov 29 2013 Dirk Krause <krause.dirk@web.de> 3.7.0-0.0.1
+- Modified dkt latex: Euro currency symbol added to translation table.
+- Modified dkma: long long, unsigned long long, intmax_t, uintmax_t.
+
+* Thu Nov 14 2013 Dirk Krause <krause.dirk@web.de> 3.6.0-0.0.1
+- Modified fig2lat: New cofop option for filled open graphics paths.
+- Bugfix in fig2lat: Must encode some characters.
+- Modified dk3ma: Function and constants names changed for consistent naming.
+
+* Wed Oct 23 2013 Dirk Krause <krause.dirk@web.de> 3.5.0-0.0.1
+- Modified wxbmpp: No automatic start when running on a directory.
+
+* Tue Oct 01 2013 Dirk Krause <krause.dirk@web.de> 3.4.0-0.0.1
+- Modified dkt blocksize: Performance optimizations, use memcpy().
+- Modified dk3sock module: Handle incomplete send requests.
+- Modified dk3str module: Use existing functions if available.
+
+* Fri Sep 20 2013 Dirk Krause <krause.dirk@web.de> 3.3.3-0.0.1
+- Option -s for dkt blocksize added.
+- Modified itadmin: Increased possible length for DHCP options values.
+- Bugfix in itadmin: DHCP options for hosts are written now.
+
+* Tue Jul 30 2013 Dirk Krause <krause.dirk@web.de> 3.3.2-0.0.1
+- Modified dk3sto module: Keyword const added to some functions.
+
+* Mon Jul 29 2013 Dirk Krause <krause.dirk@web.de> 3.3.1-0.0.1
+- Bugfix in distribution and build system.
+
+* Sun Jul 28 2013 Dirk Krause <krause.dirk@web.de> 3.3.0-0.0.1
+- API change, comparison and evaluation functions operate on const * pointers.
+
+* Wed Jul 24 2013 Dirk Krause <krause.dirk@web.de> 3.2.2-0.0.1
+- More useful error message for malformed path to dkt ls on Windows
+ (paths in double quotes where backslash escapes closing double quote).
+
+* Thu Mar 20 2013 Dirk Krause <krause.dirk@web.de> 3.0.6-0.0.1
+- dkct enhanced for unknown classes.
+
+* Wed Mar 20 2013 Dirk Krause <krause.dirk@web.de> 3.0.5-0.0.1
+- Bugfix: Use AddButton method of wxStdButtonSizer, not Add.
+
+* Sun Mar 17 2013 Dirk Krause <krause.dirk@web.de> 3.0.4-0.0.1
+- The dk3sock4 module was added.
+
+* Sat Mar 16 2013 Dirk Krause <krause.dirk@web.de> 3.0.3-0.0.1
+- Online documentation updated for the -f option in dknet.
+
+* Thu Mar 14 2013 Dirk Krause <krause.dirk@web.de> 3.0.2-0.0.1
+- The dknet program is more verbose now when run as sender.
+
+* Sun Feb 03 2013 Dirk Krause <krause.dirk@web.de> 3.0.1-0.0.1
+- The dkwxwiz program was added.
+- The winprint program (for Windows) was added.
+- The wprclean program (for Windows) was added.
+- The lprngcl program (for Windows) was added.
+- Option bbts for fig2lat.
+- Bugfix in Win32 setup: The dk3paper.conf file was not installed.
+
+* Thu Jan 31 2013 Dirk Krause <krause.dirk@web.de> 3.0.0-0.0.12
+- Code for 3.0.0 release finished.
+
+* Wed Nov 02 2011 Dirk Krause <krause.dirk@web.de> 2.2.22-0.0.1
+- Bugfix in the configure script: Unnecessary call to wx-config removed.
+
+* Tue Nov 01 2011 Dirk Krause <krause.dirk@web.de> 2.2.21-0.0.1
+- The hostsadm.pl script now adds a netgroup triple containing
+ the IP address to the netgroup.ldif file.
+- The "ctrl database-cleanup" operation for prqd now removes
+ print accounts and page counts with value 0.
+
+* Sun Jun 06 2011 Dirk Krause <krause.dirk@web.de> 2.2.20-0.0.1
+- Program imgsize renamed to chimgsize to avoid name conflicts
+ with perl-Image-Size RPM.
+
+* Sun Apr 19 2011 Dirk Krause <krause.dirk@web.de> 2.2.19-0.0.1
+- Bugfix in text2htm, wrong format specification.
+
+* Sun Nov 14 2010 Dirk Krause <krause.dirk@web.de> 2.2.18-0.0.1
+- The function dkstr_w_cat() (a fallback implementation for systems without
+ the wcscat() function) was added.
+- New programs kwintool and kwindown for Windows.
+
+* Tue Oct 26 2010 Dirk Krause <krause.dirk@web.de> 2.2.17-0.0.1
+- New option ``create accounts automatically'' for prqd. By default
+ we avoid to create personal print accounts automatically to keep
+ the database small.
+- Improvements in the GUI of the PrintLimit application.
+
+* Sun Oct 24 2010 Dirk Krause <krause.dirk@web.de> 2.2.16-0.0.1
+- New Java application PrintLimit for users of LPRng/prqd to show
+ users print quota information.
+- The dklibsj.html page was improved. Tutorial and short reference added.
+
+* Wed Oct 20 2010 Dirk Krause <krause.dirk@web.de> 2.2.15-0.0.1
+- The LANG environment variable is now tested for both ".UTF-8"
+ and ".utf8" to indicate the use of UTF-8 encoding.
+
+* Wed Sep 15 2010 Dirk Krause <krause.dirk@web.de> 2.2.14-0.0.1
+- Documentation update: Notes about differences in the appearance of
+ interpolated splines in Xfig/transfig and fig2vect. Recommendations how
+ to modify the sources of Xfig and transfig.
+
+* Tue Sep 14 2010 Dirk Krause <krause.dirk@web.de> 2.2.13-0.0.1
+- Corrected typographic errors in the DKrause::Diagram documentation.
+
+* Tue Sep 13 2010 Dirk Krause <krause.dirk@web.de> 2.2.12-0.0.1
+- The *.jar files were missing in the Windows executable setup of
+ 2.2.11. Here they are back.
+
+* Tue Aug 31 2010 Dirk Krause <krause.dirk@web.de> 2.2.11-0.0.1
+- Unnecessary line end correction removed from fig2vect.
+- New Perl module DKrause::Diagram added
+
+* Tue Jul 20 2010 Dirk Krause <krause.dirk@web.de> 2.2.10-0.0.1
+- Documentation corrections.
+
+* Fri Jul 16 2010 Dirk Krause <krause.dirk@web.de> 2.2.9-0.0.1
+- Bugfix in tracecc, application group name corrected.
+
+* Mon Jul 12 2010 Dirk Krause <krause.dirk@web.de> 2.2.8-0.0.1
+- Modifications in configure script for build process on Mac.
+
+* Sat Jun 26 2010 Dirk Krause <krause.dirk@web.de> 2.2.6-0.0.1
+- Bugfix in bmeps, bits per component reduction disabled.
+- Modifications in HTML documentation due to validation results.
+- New option "doxygen comments" for genau.
+- Script "make-pkg.sh" to build SVR4 packages.
+- Doxygen comments added.
+
+* Fri Jun 18 2010 Dirk Krause <krause.dirk@web.de> 2.2.5-0.0.1
+- Modified hostsadm: UTF-8 to ISO-LATIN-1 conversion.
+- Code cleanup.
+
+* Sun Jun 13 2010 Dirk Krause <krause.dirk@web.de> 2.2.4-0.0.1
+- File dktools.spec added.
+- Start scripts for prqd, rshdown, useraud now installed to /etc/init.d.
+
+* Sat Jun 12 2010 Dirk Krause <krause.dirk@web.de> 2.2.3-0.0.1
+- DESTDIR variable added to makefile for RPM builders.
+
+* Thu Jun 03 2010 Dirk Krause <krause.dirk@web.de> 2.2.2-0.0.1
+- Bugfix for preference file location.
+