summaryrefslogtreecommitdiff
path: root/macros/texinfo/texinfo/tp/tests/Makefile.am
diff options
context:
space:
mode:
authorNorbert Preining <norbert@preining.info>2019-09-25 03:00:48 +0000
committerNorbert Preining <norbert@preining.info>2019-09-25 03:00:48 +0000
commitd232e1107d60e7689e706bee9705f26745ae8b9e (patch)
treef9ac3303fdb36c2eca1872286615c0931d952476 /macros/texinfo/texinfo/tp/tests/Makefile.am
parent94c2e367c3690be2a3c715b4577c81200652ad81 (diff)
CTAN sync 201909250300
Diffstat (limited to 'macros/texinfo/texinfo/tp/tests/Makefile.am')
-rw-r--r--macros/texinfo/texinfo/tp/tests/Makefile.am28
1 files changed, 3 insertions, 25 deletions
diff --git a/macros/texinfo/texinfo/tp/tests/Makefile.am b/macros/texinfo/texinfo/tp/tests/Makefile.am
index 9ff2627ef4..a33e8be5a5 100644
--- a/macros/texinfo/texinfo/tp/tests/Makefile.am
+++ b/macros/texinfo/texinfo/tp/tests/Makefile.am
@@ -26,10 +26,7 @@ tex_html_tests = tex_html
DIST_SUBDIRS = many_input_files $(base_tests) $(tex_html_tests)
SUBDIRS = . many_input_files
-copy-tests: copy-base
- cd many_input_files && $(MAKE) copy-tests
-
-copy-base:
+copy-tests:
$(srcdir)/parser_tests.sh -copy $(base_tests)
copy-tex-html:
@@ -39,11 +36,7 @@ copy-tex-html:
clean-tests:
$(srcdir)/parser_tests.sh -clean $(base_tests) $(tex_html_tests)
-other_tests = \
- t/stdout.sh \
- t/stdout_split.sh
-
-TESTS = $(one_test_files_generated_list) $(other_tests)
+TESTS = $(one_test_files_generated_list)
AM_TESTS_ENVIRONMENT = srcdir="$(srcdir)"; export srcdir; top_srcdir="$(top_srcdir)"; export top_srcdir; builddir="$(builddir)"; export buildir; top_builddir="$(top_builddir)"; export top_builddir;
@@ -53,23 +46,8 @@ all-checks all-check: all
tex-html-checks tex-html-check: all
$(MAKE) $(AM_MAKEFLAGS) check TEX_HTML_TESTS=yes
-# This is done in this directory to be sure that the files are there
-# when check is done in this directory.
-# Some files are in 2 directories in order to get the same result
-# in both test run locations.
-all-local: equivalent_nodes-noderename.cnf sectioning/equivalent_nodes-noderename.cnf
-
-sectioning/equivalent_nodes-noderename.cnf: sectioning/renamednodes.cnf-ref
- ${INSTALL_DATA} $(srcdir)/sectioning/renamednodes.cnf-ref $@
-
-equivalent_nodes-noderename.cnf: sectioning/renamednodes.cnf-ref
- ${INSTALL_DATA} $(srcdir)/sectioning/renamednodes.cnf-ref $@
-
EXTRA_DIST = run_parser_all.sh parser_tests.sh \
- $(one_test_files_generated_list) coverage_macro.texi $(other_tests) reference
-
-DISTCLEANFILES = unknown_nodes_renamed-noderename.cnf \
- equivalent_nodes-noderename.cnf
+ $(one_test_files_generated_list) coverage_macro.texi
dist-hook:
rm -rf `find $(distdir)/reference -name .git`