summaryrefslogtreecommitdiff
path: root/macros/latex/contrib/sagetex/setup.py
diff options
context:
space:
mode:
authorNorbert Preining <norbert@preining.info>2019-09-02 13:46:59 +0900
committerNorbert Preining <norbert@preining.info>2019-09-02 13:46:59 +0900
commite0c6872cf40896c7be36b11dcc744620f10adf1d (patch)
tree60335e10d2f4354b0674ec22d7b53f0f8abee672 /macros/latex/contrib/sagetex/setup.py
Initial commit
Diffstat (limited to 'macros/latex/contrib/sagetex/setup.py')
-rw-r--r--macros/latex/contrib/sagetex/setup.py32
1 files changed, 32 insertions, 0 deletions
diff --git a/macros/latex/contrib/sagetex/setup.py b/macros/latex/contrib/sagetex/setup.py
new file mode 100644
index 0000000000..44631f6926
--- /dev/null
+++ b/macros/latex/contrib/sagetex/setup.py
@@ -0,0 +1,32 @@
+from distutils.core import setup
+setup(name='sagetex',
+ description='Embed Sage code and plots into LaTeX',
+ long_description="""The SageTeX package allows you to embed code,
+ results of computations, and plots from the Sage mathematics
+ software suite (http://sagemath.org) into LaTeX documents.""",
+ version='3.2',
+ author='Dan Drake',
+ author_email='dr.dan.drake@gmail.com',
+ maintainer='SageMath developers',
+ maintainer_email='sage-devel@googlegroups.com',
+ url='https://github.com/sagemath/sagetex',
+ license='GPLv2+',
+ py_modules=['sagetex'],
+ data_files = [('share/texmf/tex/latex/sagetex',
+ ['example.tex',
+ 'CONTRIBUTORS',
+ 'extractsagecode.py',
+ 'run-sagetex-if-necessary.py',
+ 'makestatic.py',
+ 'scripts.dtx',
+ 'remote-sagetex.dtx',
+ 'remote-sagetex.py',
+ 'py-and-sty.dtx',
+ 'sagetex.dtx',
+ 'sagetex.ins',
+ 'sagetexparse.py',
+ 'sagetex.sty']),
+ ('share/doc/sagetex', [
+ 'example.tex',
+ 'sagetex.pdf',
+ 'example.pdf'])])