summaryrefslogtreecommitdiff
path: root/indexing/upmendex/source/configure.ac
diff options
context:
space:
mode:
authorNorbert Preining <norbert@preining.info>2020-02-23 03:01:01 +0000
committerNorbert Preining <norbert@preining.info>2020-02-23 03:01:01 +0000
commit0908ef0004729f1b45b8d9687656f2f92fc122ae (patch)
treeaa4649a4452d4556370dc1d72c01f5d872a7c159 /indexing/upmendex/source/configure.ac
parent3549e67b13c8460a73d122fbc2eef8badd816636 (diff)
CTAN sync 202002230301
Diffstat (limited to 'indexing/upmendex/source/configure.ac')
-rw-r--r--indexing/upmendex/source/configure.ac20
1 files changed, 17 insertions, 3 deletions
diff --git a/indexing/upmendex/source/configure.ac b/indexing/upmendex/source/configure.ac
index 9a6cbfa555..c95d31520b 100644
--- a/indexing/upmendex/source/configure.ac
+++ b/indexing/upmendex/source/configure.ac
@@ -1,13 +1,14 @@
+dnl $Id$
dnl Process this file with autoconf to produce a configure script.
dnl
-dnl Copyright 2016 Karl Berry <tex-live@tug.org>
-dnl Copyright 2010-2014 Peter Breitenlohner <tex-live@tug.org>
+dnl Copyright 2015-2020 Karl Berry <tex-live@tug.org>
+dnl Copyright 2010-2015 Peter Breitenlohner <tex-live@tug.org>
dnl
dnl This file is free software; the copyright holder
dnl gives unlimited permission to copy and/or distribute it,
dnl with or without modifications, as long as this notice is preserved.
dnl
-AC_INIT([upmendex (TeX Live)], [0.52])
+AC_INIT([upmendex (TeX Live)], [0.54])
AC_PREREQ([2.63])
AC_CONFIG_SRCDIR([main.c])
AC_CONFIG_AUX_DIR([../../build-aux])
@@ -36,7 +37,20 @@ AS_CASE([$kpse_cv_have___VA_ARGS__],
[yes], [AC_DEFINE([HAVE___VA_ARGS__], 1,
[Define to 1 if you have C99 variadic macros.])])
+dnl As of ICU 65.1, ICU requires -lpthread on x86_64-linux and, most
+dnl likely, on other platforms. Otherwise there is a crash in
+dnl std::call_once, as shown in ChangeLog. OpenBSD already has to link
+dnl with -lpthread on all platforms (see m4/kpse-icu-flags.m4), but so
+dnl far it seems only upmendex requires it elsewhere. The double
+dnl inclusion of -lpthread on obsd should be harmless.
+dnl
+dnl The autoconf-archive ax_pthread macro (used in asymptote) goes to
+dnl much greater lengths to find the best thread library and support all
+dnl platforms. We can switch to that if necessary, but hopefully this
+dnl simple test will be enough.
+dnl
KPSE_KPATHSEA_FLAGS
+KPSE_SEARCH_LIBS([PTHREAD_LIB], [pthread_create], [pthread])
KPSE_ICU_FLAGS([icuio icui18n], [--ldflags-icuio])
AC_CONFIG_FILES([Makefile])