summaryrefslogtreecommitdiff
path: root/Master/texmf-dist/source/latex/thailatex/babel/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Master/texmf-dist/source/latex/thailatex/babel/Makefile.am')
-rw-r--r--Master/texmf-dist/source/latex/thailatex/babel/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/Master/texmf-dist/source/latex/thailatex/babel/Makefile.am b/Master/texmf-dist/source/latex/thailatex/babel/Makefile.am
new file mode 100644
index 00000000000..8aa92d3523a
--- /dev/null
+++ b/Master/texmf-dist/source/latex/thailatex/babel/Makefile.am
@@ -0,0 +1,34 @@
+BABEL_COMMON = thai.sty thswitch.sty lthenc.def \
+ lthkinnari.fd lthgaruda.fd lthnorasi.fd \
+ lthttype.fd lthttypist.fd \
+ lthpurisa.fd lthloma.fd \
+ lthwaree.fd lthumpush.fd \
+ lthsawasdee.fd
+
+BABEL_SRC = thai.dtx thai.ins $(BABEL_COMMON)
+BABEL_INS = thai.ldf $(BABEL_COMMON)
+BABEL_DOCS = thai.pdf
+
+EXTRA_DIST = $(BABEL_SRC)
+CLEANFILES = thai.log thai.aux thai.ldf thai.pdf
+
+babeldir = $(texmfdir)/tex/generic/babel
+babel_DATA = $(BABEL_INS)
+
+doc_DATA = $(BABEL_DOCS)
+
+thai.ldf: thai.ins thai.dtx
+ if [ ! -f thai.ins ]; then \
+ $(LN_S) $(srcdir)/thai.ins thai.ins; \
+ fi
+ if [ ! -f thai.dtx ]; then \
+ $(LN_S) $(srcdir)/thai.dtx thai.dtx; \
+ fi
+ latex thai.ins
+
+thai.pdf: thai.dtx
+ if [ ! -f thai.dtx ]; then \
+ $(LN_S) $(srcdir)/thai.dtx thai.dtx; \
+ fi
+ pdflatex thai.dtx
+