summaryrefslogtreecommitdiff
path: root/Master/texmf-dist/source/fonts/fonts-tlwg/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Master/texmf-dist/source/fonts/fonts-tlwg/tests/Makefile.am')
-rw-r--r--Master/texmf-dist/source/fonts/fonts-tlwg/tests/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/Master/texmf-dist/source/fonts/fonts-tlwg/tests/Makefile.am b/Master/texmf-dist/source/fonts/fonts-tlwg/tests/Makefile.am
new file mode 100644
index 00000000000..c7559697834
--- /dev/null
+++ b/Master/texmf-dist/source/fonts/fonts-tlwg/tests/Makefile.am
@@ -0,0 +1,36 @@
+TESTS_ENVIRONMENT = top_builddir=$(top_builddir);top_srcdir=$(top_srcdir)
+
+EXTRA_DIST = \
+ test-ttf.sh \
+ test-pfa.sh \
+ test-pfb.sh \
+ test-otf.sh \
+ gen-pdfsample.sh
+
+CONFTESTS=
+if INCLUDE_TESTFONT
+if INCLUDE_TTF
+CONFTESTS += test-ttf.sh
+endif
+#if INCLUDE_PFA
+#CONFTESTS += test-pfa.sh
+#endif
+if INCLUDE_PFB
+CONFTESTS += test-pfb.sh
+endif
+#if INCLUDE_OTF
+#CONFTESTS += test-otf.sh
+#endif
+endif
+
+TESTS = $(CONFTESTS)
+
+CLEANFILES = *.pdf
+
+check_SCRIPTS = \
+ test-ttf.sh \
+ test-pfa.sh \
+ test-pfb.sh \
+ test-otf.sh \
+ gen-pdfsample.sh
+