summaryrefslogtreecommitdiff
path: root/Build/source/utils/xindy/tex2xindy/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/utils/xindy/tex2xindy/Makefile.am')
-rw-r--r--Build/source/utils/xindy/tex2xindy/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/Build/source/utils/xindy/tex2xindy/Makefile.am b/Build/source/utils/xindy/tex2xindy/Makefile.am
index 86153718732..5464ca5db7e 100644
--- a/Build/source/utils/xindy/tex2xindy/Makefile.am
+++ b/Build/source/utils/xindy/tex2xindy/Makefile.am
@@ -34,5 +34,12 @@ CLEANFILES = tex2xindy.c
dist-hook:
rm -f $(distdir)/tex2xindy.c
-tex2xindy.1: tex2xindy.l
- pod2man --verbose -n TEX2XINDY -r "Version 1.21" -c "xindy" $< $@
+IDENT_DATE = `ident $< | grep '\$$Id' | sed -e 's/^.*,v [^ ]* //' -e 's/ .*//' -e s:/:-:g`
+IDENT_VERSION = `ident $< | grep '\$$Id' | sed -e 's/^.*,v //' -e 's/ .*//'`
+
+$(srcdir)/tex2xindy.1: $(srcdir)/tex2xindy.l
+ pod2man --center '$(PACKAGE_NAME)' \
+ --name=$(basename $@ .1 | tr '[a-z]' '[A-Z]')
+ --release "Version $(IDENT_VERSION)" \
+ --date "$(IDENT_DATE)" \
+ $< $@