summaryrefslogtreecommitdiff
path: root/Build/source/utils/xindy/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/utils/xindy/Makefile.am')
-rw-r--r--Build/source/utils/xindy/Makefile.am32
1 files changed, 17 insertions, 15 deletions
diff --git a/Build/source/utils/xindy/Makefile.am b/Build/source/utils/xindy/Makefile.am
index 900e85c699c..061d8fd8d28 100644
--- a/Build/source/utils/xindy/Makefile.am
+++ b/Build/source/utils/xindy/Makefile.am
@@ -1,6 +1,6 @@
-## Makefile.am for the TeX Live subdirectory texk/dvipng/
+## Makefile.am for the TeX Live subdirectory utils/xindy/
##
-## Copyright (C) 2009, 2010 Peter Breitenlohner <tex-live@tug.org>
+## Copyright (C) 2009 - 2011 Peter Breitenlohner <tex-live@tug.org>
## You may freely use, modify and/or distribute this file.
##
ACLOCAL_AMFLAGS = -I ../../m4
@@ -9,31 +9,33 @@ EXTRA_DIST = README-clisp
## We use the original xindy source tree.
##
-SUBDIRS = . xindy
+SUBDIRS = . $(XINDY_TREE)
+DIST_SUBDIRS = $(SUBDIRS)
## Patches applied to the original source tree
##
-EXTRA_DIST += xindy-$(VERSION)-PATCHES
+EXTRA_DIST += $(XINDY_TREE)-PATCHES
## We must explicitly distribute some top-level files.
##
EXTRA_DIST += \
- xindy/AUTHORS \
- xindy/COPYING \
- xindy/INSTALL \
- xindy/Makefile.am \
- xindy/README \
- xindy/NEWS \
- xindy/m4 \
- xindy/configure.ac
+ $(XINDY_TREE)/AUTHORS \
+ $(XINDY_TREE)/COPYING \
+ $(XINDY_TREE)/INSTALL \
+ $(XINDY_TREE)/Makefile.am \
+ $(XINDY_TREE)/README \
+ $(XINDY_TREE)/NEWS \
+ $(XINDY_TREE)/VERSION \
+ $(XINDY_TREE)/m4 \
+ $(XINDY_TREE)/configure.ac
## For future reorganisation of alphabets/Makefile.am,
## used to build alphabets/LANG/Makefile.am fragments.
##
EXTRA_DIST += \
- xindy/make-rules/alphabets/Makefile.am.not-yet \
- xindy/make-rules/alphabets/lang.defs \
- xindy/make-rules/alphabets/mk-lang.sh
+ $(XINDY_TREE)/make-rules/alphabets/Makefile.am.not-yet \
+ $(XINDY_TREE)/make-rules/alphabets/lang.defs \
+ $(XINDY_TREE)/make-rules/alphabets/mk-lang.sh
# in case of an SVN repository
dist-hook: