summaryrefslogtreecommitdiff
path: root/Build/source/utils/xindy-new/xindy/user-commands/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/utils/xindy-new/xindy/user-commands/Makefile.am')
-rw-r--r--Build/source/utils/xindy-new/xindy/user-commands/Makefile.am67
1 files changed, 67 insertions, 0 deletions
diff --git a/Build/source/utils/xindy-new/xindy/user-commands/Makefile.am b/Build/source/utils/xindy-new/xindy/user-commands/Makefile.am
new file mode 100644
index 00000000000..c77629931ef
--- /dev/null
+++ b/Build/source/utils/xindy-new/xindy/user-commands/Makefile.am
@@ -0,0 +1,67 @@
+## Use `autoreconf' in top-level directory to recreate all
+## autoconf/automake files.
+## Or, call `automake Makefile' to create only Makefile.in.
+
+## Copyright (C) 2004-2005 by Gour.
+## Copyright (C) 2008 by Joachim Schrod.
+##
+## This program is free software; you can redistribute it and/or
+## modify it under the terms of the GNU General Public License as
+## published by the Free Software Foundation; either version 2 of the
+## License, or (at your option) any later version.
+##
+## This program is distributed in the hope that it will be useful, but
+## WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+## General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program in the file COPYING; if not, write to the
+## Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
+## Boston, MA 02110-1301 USA.
+
+bin_SCRIPTS =
+scripts = texindy xindy xindy.v2
+
+if TEXLIVE_BUILD
+noinst_SCRIPTS = $(scripts)
+scriptspath = texmf/scripts/xindy
+scriptsdir = ${prefix}/$(scriptspath)
+install-exec-hook: $(scripts)
+ $(MKDIR_P) "$(DESTDIR)$(scriptsdir)"
+ @for f in $(scripts); do \
+ $(INSTALL_SCRIPT) `test -f "$$f" || echo "$(srcdir)/"`$$f $(DESTDIR)$(scriptsdir)/$$f.pl; \
+ done
+ case "$(bindir)" in \
+ */bin) $(MAKE) $(AM_MAKEFLAGS) REL=.. install-links;; \
+ */bin/*) $(MAKE) $(AM_MAKEFLAGS) REL=../.. install-links;; \
+ *) echo "strange directory '$(bindir)' for linked scripts" >&2; \
+ exit 1;; \
+ esac
+install-links:
+ @cd $(DESTDIR)$(bindir) && \
+ for f in $(scripts); do \
+ echo "creating link '$$f -> '$(REL)/$(scriptspath)/$$f.pl"; \
+ $(LN_S) $(REL)/$(scriptspath)/$$f.pl $$f; \
+ done
+uninstall-hook:
+ @for f in $(scripts); do \
+ rm -f $(DESTDIR)$(bindir)/$$f; \
+ rm -f $(DESTDIR)$(scriptsdir)/$$f.pl; \
+ done
+else !TEXLIVE_BUILD
+bin_SCRIPTS += $(scripts)
+endif !TEXLIVE_BUILD
+
+xindy: xindy.in Makefile
+ sed -e 's:@libdir\@:$(libdir):' $(srcdir)/xindy.in >xindy
+
+xindy.v2: xindy.v2.in
+ cat $(srcdir)/xindy.v2.in >xindy.v2
+
+man_MANS = texindy.1 xindy.1 xindy.v2.1
+
+EXTRA_DIST = $(man_MANS) texindy xindy.in xindy.v2.in
+
+CLEANFILES = xindy xindy.v2
+