summaryrefslogtreecommitdiff
path: root/Build/source/utils/vlna/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/utils/vlna/configure.ac')
-rw-r--r--Build/source/utils/vlna/configure.ac12
1 files changed, 5 insertions, 7 deletions
diff --git a/Build/source/utils/vlna/configure.ac b/Build/source/utils/vlna/configure.ac
index a00c07c9dfe..750d233936d 100644
--- a/Build/source/utils/vlna/configure.ac
+++ b/Build/source/utils/vlna/configure.ac
@@ -1,14 +1,11 @@
dnl configure.ac -- Peter Breitenlohner <peb@mppmu.mpg.de> -- Public domain.
-AC_PREREQ(2.62)
+AC_PREREQ(2.60)
AC_INIT([vlna], [1.3], [tex-live@tug.org])
AC_CONFIG_SRCDIR([vlna.w])
AM_INIT_AUTOMAKE([foreign no-define])dnl using automake
-AM_MAINTAINER_MODE[]dnl maintainer mode only if requested
-AC_DISABLE_OPTION_CHECKING[]dnl disable warning for unrecognized inherited options
-
# Checks for programs.
AC_PROG_CC
AC_PROG_MAKE_SET
@@ -19,15 +16,16 @@ AC_CHECK_PROGS([CTANGLE], [ctangle], [none])
AC_CHECK_PROGS([CWEAVE], [cweave], [none])
AC_CHECK_PROGS([CSPLAIN], [csplain], [none])
-if test x"$USE_MAINTAINER_MODE" = xyes; then
+if test x"$enable_maintainer_mode" = xyes; then
case :$CTANGLE:$CWEAVE:$CSPLAIN: in
*:none:*)
- AC_MSG_ERROR([Maintainer mode requires ctangle, cweave, and csplain in your PATH.])
+ AC_MSG_WARN([Maintainer mode disabled -- requires ctangle, cweave, and csplain.])
+ enable_maintainer_mode=no
;;
esac
fi
-AM_CONDITIONAL([TETEX_BUILD], [test x"$enable_tetex_build" = xyes])
+AM_MAINTAINER_MODE[]dnl maintainer mode only if requested
AC_CONFIG_FILES([Makefile])
AC_OUTPUT