summaryrefslogtreecommitdiff
path: root/Build/source/utils/sam2p/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/utils/sam2p/debian/rules')
-rwxr-xr-xBuild/source/utils/sam2p/debian/rules69
1 files changed, 0 insertions, 69 deletions
diff --git a/Build/source/utils/sam2p/debian/rules b/Build/source/utils/sam2p/debian/rules
deleted file mode 100755
index 71ddf1a626b..00000000000
--- a/Build/source/utils/sam2p/debian/rules
+++ /dev/null
@@ -1,69 +0,0 @@
-#!/usr/bin/make -f
-# Made with the aid of debmake, by Christoph Lameter,
-# based on the sample debian/rules file for GNU hello by Ian Jackson.
-
-package=sam2p
-
-build:
- $(checkdir)
- ./configure --enable-gif --enable-lzw --prefix=/usr
- $(MAKE)
- touch build
-
-clean:
- $(checkdir)
- -rm -f build
- -$(MAKE) MAKE_DIST=1 clean
- -rm -f `find . -name "*~"`
- -rm -rf debian/tmp debian/files* core debian/substvars
-# Dat: make distclean would remove the `configure' script
-
-binary-indep: checkroot build
- $(checkdir)
-# There are no architecture-independent files to be uploaded
-# generated by this package. If there were any they would be
-# made here.
-
-binary-arch: checkroot build
- $(checkdir)
- -rm -rf debian/tmp
- install -d debian/tmp
- cd debian/tmp && install -d `cat ../dirs`
- $(MAKE) install prefix=`pwd`/debian/tmp/usr DESTDIR=`pwd`/debian/tmp/usr
-# Must have debmake installed for this to work. Otherwise please copy
-# /usr/bin/debstd into the debian directory and change debstd to debian/debstd
- debstd README README.1 README.2 README.3 README.4 README.5 README.6 README~
- dpkg-gencontrol -isp
- chown -R root.root debian/tmp
- chmod -R go=rX debian/tmp
- dpkg --build debian/tmp ..
-
-define checkdir
- test -f debian/rules
-endef
-
-binary:
- $(checkdir)
- if test root = "`whoami`"; then $(MAKE) -f debian/rules binary-indep binary-arch; \
- else fakeroot $(MAKE) -f debian/rules binary-indep binary-arch; fi
-
-checkroot:
- $(checkdir)
- test root = "`whoami`"
-
-.PHONY: binary binary-arch binary-indep clean checkroot
-
-.PHONY: source source-here
-source-here:
- rm -rf debsrc
- mkdir -p debsrc/debian
- cp -a $(wildcard $(addprefix debian/,README.debian docs changelog control copyright dirs rules prerm postrm postinst preinst)) debsrc/debian
- $(MAKEF) install-debsrc
- DIR="`<debian/changelog perl -ne 'print if s@^(\S+) [(]([^)]+?)(?:-\d+)?[)].*@$$1-$$2@;last'`" && \
- test ! -d "$$DIR" && \
- mv debsrc "$$DIR" && \
- (dpkg-source -b "$$DIR";true) && \
- rm -rf "$$DIR"
-
-source: source-here
- mv $(package)_*-*.tar.gz $(package)_*-*.dsc ..