summaryrefslogtreecommitdiff
path: root/Build/source/utils/m-tx/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/utils/m-tx/Makefile.am')
-rw-r--r--Build/source/utils/m-tx/Makefile.am68
1 files changed, 34 insertions, 34 deletions
diff --git a/Build/source/utils/m-tx/Makefile.am b/Build/source/utils/m-tx/Makefile.am
index 452ef4735a0..2a0f8f7b63a 100644
--- a/Build/source/utils/m-tx/Makefile.am
+++ b/Build/source/utils/m-tx/Makefile.am
@@ -1,6 +1,6 @@
## Makefile.am for the TeX Live subdirectory utils/m-tx/
##
-## Copyright (C) 2012 Peter Breitenlohner <tex-live@tug.org>
+## Copyright (C) 2012, 2013 Peter Breitenlohner <tex-live@tug.org>
## You may freely use, modify and/or distribute this file.
##
ACLOCAL_AMFLAGS = -I ../../m4
@@ -12,7 +12,7 @@ EXTRA_DIST += $(MTX_TREE)-PATCHES
# in case of an SVN repository
dist-hook:
- rm -rf `find $(distdir) -name .svn`
+ rm -rf `find $(distdir) -name .svn -o -name .deps -o -name .dirstamp -o -name '*.$(OBJEXT)'`
AM_CPPFLAGS = -I$(srcdir)/$(MTX_TREE)/libp2c -DNO_DECLARE_MALLOC
AM_CFLAGS = #$(WARNING_CFLAGS)
@@ -20,39 +20,39 @@ AM_CFLAGS = #$(WARNING_CFLAGS)
bin_PROGRAMS = prepmx
prepmx_SOURCES = \
- $(MTX_TREE)/analyze.c \
- $(MTX_TREE)/analyze.h \
- $(MTX_TREE)/cfuncs.c \
- $(MTX_TREE)/cfuncs.h \
- $(MTX_TREE)/control.c \
- $(MTX_TREE)/control.h \
- $(MTX_TREE)/files.c \
- $(MTX_TREE)/files.h \
- $(MTX_TREE)/globals.c \
- $(MTX_TREE)/globals.h \
- $(MTX_TREE)/libp2c/p2c.h \
- $(MTX_TREE)/lyrics.c \
- $(MTX_TREE)/lyrics.h \
- $(MTX_TREE)/mtx.c \
- $(MTX_TREE)/mtx.h \
- $(MTX_TREE)/mtxline.c \
- $(MTX_TREE)/mtxline.h \
- $(MTX_TREE)/multfile.c \
- $(MTX_TREE)/multfile.h \
- $(MTX_TREE)/notes.c \
- $(MTX_TREE)/notes.h \
- $(MTX_TREE)/preamble.c \
- $(MTX_TREE)/preamble.h \
- $(MTX_TREE)/prepmx.c \
- $(MTX_TREE)/status.c \
- $(MTX_TREE)/status.h \
- $(MTX_TREE)/strings.h \
- $(MTX_TREE)/uptext.c \
- $(MTX_TREE)/uptext.h \
- $(MTX_TREE)/utility.c \
- $(MTX_TREE)/utility.h
+ @MTX_TREE@/analyze.c \
+ @MTX_TREE@/analyze.h \
+ @MTX_TREE@/cfuncs.c \
+ @MTX_TREE@/cfuncs.h \
+ @MTX_TREE@/control.c \
+ @MTX_TREE@/control.h \
+ @MTX_TREE@/files.c \
+ @MTX_TREE@/files.h \
+ @MTX_TREE@/globals.c \
+ @MTX_TREE@/globals.h \
+ @MTX_TREE@/libp2c/p2c.h \
+ @MTX_TREE@/lyrics.c \
+ @MTX_TREE@/lyrics.h \
+ @MTX_TREE@/mtx.c \
+ @MTX_TREE@/mtx.h \
+ @MTX_TREE@/mtxline.c \
+ @MTX_TREE@/mtxline.h \
+ @MTX_TREE@/multfile.c \
+ @MTX_TREE@/multfile.h \
+ @MTX_TREE@/notes.c \
+ @MTX_TREE@/notes.h \
+ @MTX_TREE@/preamble.c \
+ @MTX_TREE@/preamble.h \
+ @MTX_TREE@/prepmx.c \
+ @MTX_TREE@/status.c \
+ @MTX_TREE@/status.h \
+ @MTX_TREE@/strings.h \
+ @MTX_TREE@/uptext.c \
+ @MTX_TREE@/uptext.h \
+ @MTX_TREE@/utility.c \
+ @MTX_TREE@/utility.h
-## We can not use $(MTX_TREE)/libp2c/p2clib.c (multiple definitions).
+## We can not use @MTX_TREE@/libp2c/p2clib.c (multiple definitions).
dist_man1_MANS = m-tx.1 prepmx.1