summaryrefslogtreecommitdiff
path: root/Build/source/utils/lcdf-typetools/otftotfm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/utils/lcdf-typetools/otftotfm/Makefile.am')
-rw-r--r--Build/source/utils/lcdf-typetools/otftotfm/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/Build/source/utils/lcdf-typetools/otftotfm/Makefile.am b/Build/source/utils/lcdf-typetools/otftotfm/Makefile.am
new file mode 100644
index 00000000000..9f320107499
--- /dev/null
+++ b/Build/source/utils/lcdf-typetools/otftotfm/Makefile.am
@@ -0,0 +1,28 @@
+## Process this file with automake to produce Makefile.in
+AUTOMAKE_OPTIONS = foreign
+
+bin_PROGRAMS = otftotfm
+man_MANS = otftotfm.1
+
+otftotfm_SOURCES = \
+ automatic.cc automatic.hh \
+ dvipsencoding.cc dvipsencoding.hh \
+ glyphfilter.cc glyphfilter.hh \
+ md5.c md5.h \
+ metrics.cc metrics.hh \
+ otftotfm.cc otftotfm.hh \
+ secondary.cc secondary.hh \
+ uniprop.cc uniprop.hh \
+ util.cc util.hh
+EXTRA_otftotfm_SOURCES = kpseinterface.c kpseinterface.h
+
+otftotfm_LDADD = ../libefont/libefont.a ../liblcdf/liblcdf.a @KPSEINTERFACE_O@ @LIBKPATHSEA@
+otftotfm_DEPENDENCIES = ../libefont/libefont.a ../liblcdf/liblcdf.a @KPSEINTERFACE_O@ @LIBKPATHSEA_DEP@
+
+INCLUDES = -I$(top_srcdir)/include
+CLEANFILES = @TEMPLATE_OBJS@
+
+EXTRA_DIST = otftotfm.1
+
+$(top_builddir)/../../texk/kpathsea/.libs/libkpathsea.a:
+ cd $(top_builddir)/../../texk/kpathsea && $(MAKE)