summaryrefslogtreecommitdiff
path: root/Build/source/utils/dialog/dialog-1.1-20110707/package/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/utils/dialog/dialog-1.1-20110707/package/debian/rules')
-rwxr-xr-xBuild/source/utils/dialog/dialog-1.1-20110707/package/debian/rules95
1 files changed, 0 insertions, 95 deletions
diff --git a/Build/source/utils/dialog/dialog-1.1-20110707/package/debian/rules b/Build/source/utils/dialog/dialog-1.1-20110707/package/debian/rules
deleted file mode 100755
index fae0138249d..00000000000
--- a/Build/source/utils/dialog/dialog-1.1-20110707/package/debian/rules
+++ /dev/null
@@ -1,95 +0,0 @@
-#!/usr/bin/make -f
-# MAde with the aid of dh_make, by Craig Small
-# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
-# Some lines taken from debmake, by Cristoph Lameter.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
-CFLAGS =
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
- INSTALL_PROGRAM += -s
-endif
-
-
-configure: configure-stamp
-configure-stamp:
- dh_testdir
-
- CFLAGS="$(CFLAGS)" ./configure \
- --host=$(DEB_HOST_GNU_TYPE) \
- --build=$(DEB_BUILD_GNU_TYPE) \
- --prefix=/usr \
- --mandir=\$${prefix}/share/man \
- --enable-nls \
- --enable-header-subdir \
- --enable-widec \
- --with-libtool \
- --with-ncursesw \
- --with-package=cdialog \
- --disable-rpath-hack
-
- touch configure-stamp
-
-build: build-stamp
-build-stamp: configure-stamp
- dh_testdir
-
- $(MAKE)
-
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
-
- [ ! -f makefile ] || $(MAKE) distclean
-
- rm -f configure-stamp build-stamp install-stamp
-
- dh_clean
-
-install: install-stamp
-install-stamp: build-stamp
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- $(MAKE) install DESTDIR=$(CURDIR)/debian/cdialog
-
- touch install-stamp
-
-# Build architecture-independent files here.
-binary-indep: build install
-# No binary-indep target.
-
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installdocs
- dh_installexamples
- dh_installchangelogs CHANGES
- dh_strip
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install install-stamp