summaryrefslogtreecommitdiff
path: root/Build/source/utils/devnag/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/utils/devnag/Makefile.am')
-rw-r--r--Build/source/utils/devnag/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/Build/source/utils/devnag/Makefile.am b/Build/source/utils/devnag/Makefile.am
new file mode 100644
index 00000000000..9a17e26a6f6
--- /dev/null
+++ b/Build/source/utils/devnag/Makefile.am
@@ -0,0 +1,34 @@
+## Makefile.am for the TeX Live subdirectory utils/devnag/
+##
+## Copyright 2009-2014 Peter Breitenlohner <tex-live@tug.org>
+## You may freely use, modify and/or distribute this file.
+##
+AM_CPPFLAGS = -DTEXLIVE
+
+AM_CFLAGS = $(WARNING_CFLAGS)
+
+bin_PROGRAMS = devnag
+
+devnag_SOURCES = src/devnag.c
+
+$(devnag_OBJECTS): config.force
+
+config.force: $(KPATHSEA_DEPEND)
+ echo timestamp >config.force
+ $(SHELL) ./config.status --recheck
+
+DISTCLEANFILES = config.force
+
+## Tests.
+##
+TESTS = tests/devnag.test
+EXTRA_DIST = $(TESTS)
+## tests/devnag.test
+EXTRA_DIST += \
+ tests/captions.dn tests/captions.tex \
+ tests/examples.dn tests/examples.tex \
+ tests/misspaal.dn tests/misspaal.tex \
+ tests/vedasample.dn tests/vedasample.tex
+
+DISTCLEANFILES += captions.dn examples.dn *.tex
+