summaryrefslogtreecommitdiff
path: root/Build/source/utils/biber/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/utils/biber/Makefile.am')
-rw-r--r--Build/source/utils/biber/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/Build/source/utils/biber/Makefile.am b/Build/source/utils/biber/Makefile.am
new file mode 100644
index 00000000000..0f461e34e97
--- /dev/null
+++ b/Build/source/utils/biber/Makefile.am
@@ -0,0 +1,20 @@
+# See ./README for our basic strategy here.
+#
+# Copyright 2011 Karl Berry <tex-live@tug.org>
+#
+# This file is free software; the copyright holder
+# gives unlimited permission to copy and/or distribute it,
+# with or without modifications, as long as this notice is preserved.
+
+if TL_HAVE_BIBER_BINARY
+#
+bin_SCRIPTS = biber
+tl_platform = $(TL_PLATFORM)
+#
+biber: biber.$(tl_platform)
+ rm -f biber
+ cp "$(srcdir)/biber.$(tl_platform)" biber
+
+# if the biber binary for the current platform is not present,
+# nothing to do.
+endif