summaryrefslogtreecommitdiff
path: root/Build/source/utils/asymptote/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/utils/asymptote/configure.ac')
-rw-r--r--Build/source/utils/asymptote/configure.ac11
1 files changed, 7 insertions, 4 deletions
diff --git a/Build/source/utils/asymptote/configure.ac b/Build/source/utils/asymptote/configure.ac
index 83cb1f949a3..a2888d121d0 100644
--- a/Build/source/utils/asymptote/configure.ac
+++ b/Build/source/utils/asymptote/configure.ac
@@ -3,7 +3,7 @@
# this file.
AC_PREREQ(2)
-AC_INIT([Asymptote],[2.44],[http://sourceforge.net/projects/asymptote])
+AC_INIT([Asymptote],[2.47],[http://sourceforge.net/projects/asymptote])
VERSION=$PACKAGE_VERSION
AC_SUBST(VERSION)
m4_include([ax_pthread.m4])
@@ -218,9 +218,12 @@ AC_ARG_ENABLE(gc-full-debug,
fi
])
-if test "$OSTYPE" = "msdos"; then
INCL=$INCL" -I/usr/include/tirpc"
+
+if test "$OSTYPE" = "msdos"; then
CPPFLAGS=$CPPFLAGS" -D__MSDOS__ $INCL"
+else
+CPPFLAGS=$CPPFLAGS" $INCL"
fi
AC_CHECK_FUNC(getopt_long_only, AC_DEFINE(HAVE_GNU_GETOPT_H, 1,
@@ -281,9 +284,9 @@ AC_CHECK_FUNCS([feenableexcept])
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([#include "xstream.h"])],
- [AC_SEARCH_LIBS([xdrstdio_create],[nsl rpc])
+ [AC_SEARCH_LIBS([xdrstdio_create],[nsl tirpc])
AC_DEFINE(HAVE_RPC_RPC_H, 1,
- [Define if you have a working <rpc/rpc.h> header file])],
+ [Define if you have a working <tirpc/rpc/rpc.h> header file])],
AC_MSG_WARN([*** Broken rpc headers; XDR support disabled ***]))
AC_ARG_ENABLE(gsl,