summaryrefslogtreecommitdiff
path: root/Build/source/texk/xdvik/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/xdvik/configure.ac')
-rw-r--r--Build/source/texk/xdvik/configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/Build/source/texk/xdvik/configure.ac b/Build/source/texk/xdvik/configure.ac
index 666a249e7d6..aa497f8120e 100644
--- a/Build/source/texk/xdvik/configure.ac
+++ b/Build/source/texk/xdvik/configure.ac
@@ -24,6 +24,16 @@ KPSE_T1LIB_FLAGS
XDVIK_VERSION=xdvik_version
AC_SUBST([XDVIK_VERSION])
+AC_CONFIG_SUBDIRS([squeeze])
+
AC_CONFIG_FILES([Makefile])
+dnl The subdirectory squeeze must be configured for the build system.
+dnl Can not share the cache file with the subdirectory!
+AC_CONFIG_COMMANDS_POST([AS_IF([test "x$cross_compiling" = xyes],
+[cache_file=/dev/null
+ ac_configure_args="$ac_configure_args --host='$build' \
+ CC='$BUILDCC' CPPFLAGS='$BUILDCPPFLAGS'\
+ CFLAGS='$BUILDCFLAGS' LDFLAGS='$BUILDLDFLAGS'"])])
+
AC_OUTPUT