summaryrefslogtreecommitdiff
path: root/Build/source/texk/web2c/ptexdir/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/web2c/ptexdir/lib/Makefile.am')
-rw-r--r--Build/source/texk/web2c/ptexdir/lib/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/Build/source/texk/web2c/ptexdir/lib/Makefile.am b/Build/source/texk/web2c/ptexdir/lib/Makefile.am
new file mode 100644
index 00000000000..c47cc958b8d
--- /dev/null
+++ b/Build/source/texk/web2c/ptexdir/lib/Makefile.am
@@ -0,0 +1,19 @@
+## Makefile.am for the TeX Live subdirectory texk/web2c/ptexdir/lib/
+##
+## Copyright (C) 2009 Peter Breitenlohner <tex-live@tug.org>
+## You may freely use, modify and/or distribute this file.
+##
+INCLUDES = -I$(top_builddir)/.. -I$(top_srcdir) $(KPATHSEA_INCLUDES)
+AM_CFLAGS = $(WARNING_CFLAGS)
+
+## Rebuild libkpathsea
+@KPATHSEA_RULE@
+
+noinst_LIBRARIES = lib.a
+
+## We don't compile `texmfmp.c'; this file is converted into 'texextra.c'
+## for TeX, 'mfextra.c' for Metafont, 'mfextra.c' for MetaPost, ...
+lib_a_SOURCES = \
+ openclose.c \
+ printversion.c \
+ usage.c