summaryrefslogtreecommitdiff
path: root/Build/source/texk/web2c/omegafonts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/web2c/omegafonts/Makefile.am')
-rw-r--r--Build/source/texk/web2c/omegafonts/Makefile.am24
1 files changed, 15 insertions, 9 deletions
diff --git a/Build/source/texk/web2c/omegafonts/Makefile.am b/Build/source/texk/web2c/omegafonts/Makefile.am
index bc3fda25aaa..4c5bfd00405 100644
--- a/Build/source/texk/web2c/omegafonts/Makefile.am
+++ b/Build/source/texk/web2c/omegafonts/Makefile.am
@@ -1,6 +1,6 @@
## Makefile.am for the TeX Live subdirectory texk/web2c/omegafonts/
##
-## Copyright (C) 2009-2013 Peter Breitenlohner <tex-live@tug.org>
+## Copyright (C) 2009-2014 Peter Breitenlohner <tex-live@tug.org>
## You may freely use, modify and/or distribute this file.
##
AM_CPPFLAGS = -I$(top_builddir)/.. -I$(top_srcdir) $(KPATHSEA_INCLUDES) -DNOT_WEB2C
@@ -18,12 +18,10 @@ $(proglib): ${top_srcdir}/lib/*.c
bin_PROGRAMS =
if OTANGLE
-if OMFONTS
bin_PROGRAMS += omfonts
if WIN32
noinst_PROGRAMS = call_omfonts
endif WIN32
-endif OMFONTS
endif OTANGLE
EXTRA_PROGRAMS = omfonts
@@ -82,7 +80,6 @@ bin_links = \
include $(top_srcdir)/../../am/bin_links.am
if OTANGLE
-if OMFONTS
install-exec-hook: install-bin-links
if WIN32
for f in $(linked_programs); do \
@@ -95,17 +92,14 @@ if WIN32
rm -f $(DESTDIR)$(bindir)/$$f$(EXEEXT); \
done
endif WIN32
-endif OMFONTS
endif OTANGLE
## Tests
##
-OMFONTS_tests = charwd.test level1.test omfonts.test realnum.test \
- repeat.test selectfont.test specialhex.test
+OMFONTS_tests = charwd.test level1.test ofonts.test omfonts.test overbmp.test \
+ realnum.test repeat.test selectfont.test specialhex.test
if OTANGLE
-if OMFONTS
TESTS = $(OMFONTS_tests)
-endif OMFONTS
endif OTANGLE
EXTRA_DIST = $(OMFONTS_tests)
@@ -116,11 +110,23 @@ DISTCLEANFILES += tests/charwdr.* tests/charwdv.*
## level1.test
EXTRA_DIST += tests/level1.opl
DISTCLEANFILES += tests/xlevel1.ofm tests/xlevel1.opl
+## ofonts.test
+EXTRA_DIST += tests/ofontr0.pl \
+ tests/ofontr1.pl tests/ofontr1.vpl \
+ tests/ofontr2.opl tests/ofontr2.ovp \
+ tests/ofontr3.opl tests/ofontr3.ovp \
+ tests/ofontv4.pl tests/ofontv4.vpl \
+ tests/ofontv5.opl tests/ofontv5.ovp \
+ tests/ofontv6.opl tests/ofontv6.ovp
+DISTCLEANFILES += tests/xofont*
## omfonts.test
EXTRA_DIST += tests/Cherokee.pl tests/OCherokee.ovp
DISTCLEANFILES += tests/Cherokee.tfm tests/OCherokee.ofm \
tests/OCherokee.opl tests/OCherokee.ovf \
tests/xCherokee.* tests/xOCherokee.*
+## overbmp.test
+EXTRA_DIST += tests/inbmp.opl tests/overbmp.opl tests/overbmp.ovp
+DISTCLEANFILES += tests/xinbmp* tests/xoverbmp*
## realnum.test
EXTRA_DIST += tests/realnum.opl tests/realnum.out
DISTCLEANFILES += tests/realnum.*