summaryrefslogtreecommitdiff
path: root/Build/source/texk/web2c/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/web2c/configure.ac')
-rw-r--r--Build/source/texk/web2c/configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/Build/source/texk/web2c/configure.ac b/Build/source/texk/web2c/configure.ac
index ff09815ffe9..73fdcd52a93 100644
--- a/Build/source/texk/web2c/configure.ac
+++ b/Build/source/texk/web2c/configure.ac
@@ -228,6 +228,9 @@ if test `(uname) 2>/dev/null` = aux; then
fi
AC_CHECK_SIZEOF([int])
+if test $ac_cv_sizeof_int -lt 4; then
+ AC_MSG_ERROR([Sorry, need `int' with at least 4 bytes.])
+fi
AC_CHECK_SIZEOF([long])
AC_SEARCH_LIBS([pow], [m])
AC_CHECK_FUNCS([access atoi fmax ftime gettimeofday mkdtemp setlocale snprintf stat64 strerror strlcat strlcpy])