summaryrefslogtreecommitdiff
path: root/Build/source/texk/web2c/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/web2c/Makefile.am')
-rw-r--r--Build/source/texk/web2c/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Build/source/texk/web2c/Makefile.am b/Build/source/texk/web2c/Makefile.am
index 503d530848f..e6de8dbd64b 100644
--- a/Build/source/texk/web2c/Makefile.am
+++ b/Build/source/texk/web2c/Makefile.am
@@ -33,6 +33,7 @@ EXTRA_LIBRARIES =
EXTRA_DIST = PROJECTS cftests config.h cpascal.h help.h
DISTCLEANFILES = $(EXTRA_LIBRARIES)
CLEANFILES =
+TRIPTRAP =
# in case of an SVN repository
dist-hook:
@@ -118,6 +119,12 @@ DIFF = diff
DIFFFLAGS =
TESTS_ENVIRONMENT = DIFF='$(DIFF)' DIFFFLAGS='$(DIFFFLAGS)' LN_S='$(LN_S)' KPSEWHICH='$(KPSEWHICH)'
+.PHONY: triptrap
+triptrap:
+ srcdir=$(srcdir) MAKE=$(MAKE) \
+ $(SHELL) $(srcdir)/triptrap-sh $(TRIPTRAP)
+EXTRA_DIST += triptrap-sh
+
# The environment for making dumps.
# No need to specify TEXMF, as ../kpathsea/texmf.cnf should contain
# suitable absolute paths at this point. Those are converted to