summaryrefslogtreecommitdiff
path: root/Build/source/texk/ttfdump/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/ttfdump/configure.in')
-rw-r--r--Build/source/texk/ttfdump/configure.in10
1 files changed, 6 insertions, 4 deletions
diff --git a/Build/source/texk/ttfdump/configure.in b/Build/source/texk/ttfdump/configure.in
index b8045b7c8d5..7b5ab86ac91 100644
--- a/Build/source/texk/ttfdump/configure.in
+++ b/Build/source/texk/ttfdump/configure.in
@@ -1,5 +1,6 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT(include/ttf.h)
+AC_INIT
+AC_CONFIG_SRCDIR([include/ttf.h])
dnl Checks for programs.
AC_PROG_CC
@@ -13,7 +14,7 @@ dnl Checks for header files.
AC_HEADER_STDC
dnl Checks for typedefs, structures, and compiler characteristics.
-AC_C_CROSS
+
AC_C_BIGENDIAN
AC_CHECK_SIZEOF(int)
AC_CHECK_SIZEOF(long)
@@ -25,5 +26,6 @@ AC_CHECK_FUNCS(strstr)
AC_CONFIG_HEADER(config.h)
-AC_OUTPUT(libttf/Makefile src/Makefile Makefile,
-[test -z "$CONFIG_HEADERS" || echo timestamp > stamp-h])
+AC_CONFIG_FILES([libttf/Makefile src/Makefile Makefile])
+AC_CONFIG_COMMANDS([default],[test -z "$CONFIG_HEADERS" || echo timestamp > stamp-h],[])
+AC_OUTPUT