summaryrefslogtreecommitdiff
path: root/Build/source/texk/ttf2pk2/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/ttf2pk2/configure.ac')
-rw-r--r--Build/source/texk/ttf2pk2/configure.ac41
1 files changed, 41 insertions, 0 deletions
diff --git a/Build/source/texk/ttf2pk2/configure.ac b/Build/source/texk/ttf2pk2/configure.ac
new file mode 100644
index 00000000000..db1c1cbd3f9
--- /dev/null
+++ b/Build/source/texk/ttf2pk2/configure.ac
@@ -0,0 +1,41 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl Copyright (C) 2011-2013 Peter Breitenlohner <tex-live@tug.org>
+dnl
+dnl This file is free software; the copyright holder
+dnl gives unlimited permission to copy and/or distribute it,
+dnl with or without modifications, as long as this notice is preserved.
+dnl
+AC_INIT([ttf2pk2 (TeX Live)], [2.0], [tex-k@tug.org])
+AC_PREREQ([2.65])
+AC_CONFIG_SRCDIR([ttf2pk.c])
+AC_CONFIG_AUX_DIR([../../build-aux])
+AC_CONFIG_MACRO_DIR([../../m4])
+
+dnl Common code for all programs using libkpathsea.
+KPSE_COMMON([ttf2pk], [no-define])
+
+AC_CONFIG_HEADERS([config.h])
+
+m4_include([../../version.ac])[] dnl define tex_live_version
+AC_DEFINE([TL_VERSION], ["TeX Live tex_live_version()"],
+ [Define to the current TeX Live version string.])
+
+AC_SEARCH_LIBS([floor], [m])
+
+KPSE_KPATHSEA_FLAGS
+KPSE_FREETYPE2_FLAGS
+
+if test "x$enable_build" != xno || test -f config.force; then
+
+KPSE_ADD_FLAGS([kpathsea])
+AC_CHECK_HEADER([kpathsea/version.h], [],
+ [AC_MSG_ERROR([Sorry, kpathsea too old])])
+KPSE_RESTORE_FLAGS
+
+echo timestamp >config.force
+fi
+
+AC_CONFIG_FILES([Makefile])
+
+AC_OUTPUT