summaryrefslogtreecommitdiff
path: root/Build/source/texk/tetex/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/tetex/Makefile.am')
-rw-r--r--Build/source/texk/tetex/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/Build/source/texk/tetex/Makefile.am b/Build/source/texk/tetex/Makefile.am
index 6aa2b88b715..97c088d2ad3 100644
--- a/Build/source/texk/tetex/Makefile.am
+++ b/Build/source/texk/tetex/Makefile.am
@@ -159,9 +159,10 @@ EXTRA_DIST += \
## This target is invoked by the top-level make,
## to create the per-format engine symlinks in $(bindir),
## after everything else is installed. We explicitly specify the
-## fmtutil.cnf file to use for the sake of distro builds. Also, that way
-## we don't have to run mktexlsr also.
-run_texlinks = $(bindir)/texlinks -f $(web2cdir)/fmtutil.cnf
+## fmtutil.cnf file to use for the sake of distro builds.
+## We pass along the executable extension for the sake of cygwin, so we
+## don't create dangling symlinks there (even though they work).
+run_texlinks = $(bindir)/texlinks -v -f $(web2cdir)/fmtutil.cnf -e "$(EXEEXT)"
run-texlinks:
PATH="$(bindir):$(PATH)"; export PATH; $(run_texlinks)