summaryrefslogtreecommitdiff
path: root/Build/source/texk/ptexenc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/ptexenc/Makefile.am')
-rw-r--r--Build/source/texk/ptexenc/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/Build/source/texk/ptexenc/Makefile.am b/Build/source/texk/ptexenc/Makefile.am
new file mode 100644
index 00000000000..75e136c1d16
--- /dev/null
+++ b/Build/source/texk/ptexenc/Makefile.am
@@ -0,0 +1,43 @@
+## Makefile.am for the TeX Live subdirectory texk/ptexenc/
+##
+## Copyright (C) 2009 Peter Breitenlohner <tex-live@tug.org>
+## You may freely use, modify and/or distribute this file.
+##
+ACLOCAL_AMFLAGS = -I ../../m4
+
+EXTRA_DIST = COPYRIGHT ChangeLog README
+
+INCLUDES = -I$(top_builddir)/.. -I$(top_srcdir)/..
+AM_CFLAGS = $(WARNING_CFLAGS)
+
+lib_LTLIBRARIES = libptexenc.la
+
+libptexenc_la_CPPFLAGS = -DMAKE_KPSE_DLL
+
+libptexenc_la_LDFLAGS = -version-number $(PTEXENC_LT_VERSNUM)
+
+libptexenc_la_LIBADD = $(LTLIBOBJS)
+
+## Put tex-file.c first, because it's what depends on the paths, and may
+## reduce frustration if the paths are wrong by doing it first.
+libptexenc_la_SOURCES = \
+ ptexenc.c kanjicnv.c unicode.c unicode-jp.c
+
+$(libptexenc_la_OBJECTS): kanjicnv.h ptexenc.h unicode-jp.h unicode.h
+
+ptexencincludedir = ${includedir}/ptexenc
+
+nodist_ptexencinclude_HEADERS = \
+ c-auto.h
+
+ptexencinclude_HEADERS = kanjicnv.h ptexenc.h unicode-jp.h unicode.h
+
+## Eventually delete these files
+##
+EXTRA_DIST += \
+ patches/jmpost-0.04b-ptexenc.patch \
+ patches/makejvf-1.1a-ptexenc.patch \
+ patches/mendexk2.6f-ptexenc.patch \
+ patches/ptex-src-3.1.11-ptexenc.patch \
+ patches/texlive2009-ptexenc.patch \
+ patches/texlive2009.sh