summaryrefslogtreecommitdiff
path: root/Build/source/texk/psutils/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/psutils/configure.ac')
-rw-r--r--Build/source/texk/psutils/configure.ac19
1 files changed, 18 insertions, 1 deletions
diff --git a/Build/source/texk/psutils/configure.ac b/Build/source/texk/psutils/configure.ac
index 0e493ca683d..aa6249d229a 100644
--- a/Build/source/texk/psutils/configure.ac
+++ b/Build/source/texk/psutils/configure.ac
@@ -17,7 +17,24 @@ KPSE_COMMON([psutils])
AC_CONFIG_HEADERS([config.h])
-AH_BOTTOM([#include <kpathsea/getopt.h>])
+AH_TOP([#ifndef _PSUTILS_CONFIG_H
+#define _PSUTILS_CONFIG_H 1])
+AH_BOTTOM([#include <kpathsea/kpathsea.h>
+
+#define _Noreturn
+#define _GL_ATTRIBUTE_CONST
+
+#ifdef WIN32
+# define set_binary_mode(file, mode) _setmode(file, mode)
+# ifndef __MINGW32__
+# define ftello _ftelli64
+# define fseeko _fseeki64
+# endif
+#else
+# define set_binary_mode(file, mode) 0
+#endif
+
+#endif /* _PSUTILS_CONFIG_H */])
KPSE_KPATHSEA_FLAGS
KPSE_LIBPAPER_FLAGS