summaryrefslogtreecommitdiff
path: root/Build/source/texk/kpathsea/win32/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/kpathsea/win32/Makefile.am')
-rw-r--r--Build/source/texk/kpathsea/win32/Makefile.am73
1 files changed, 0 insertions, 73 deletions
diff --git a/Build/source/texk/kpathsea/win32/Makefile.am b/Build/source/texk/kpathsea/win32/Makefile.am
deleted file mode 100644
index 3447a3dbde5..00000000000
--- a/Build/source/texk/kpathsea/win32/Makefile.am
+++ /dev/null
@@ -1,73 +0,0 @@
-## Makefile.am for the TeX Live subdirectory texk/kpathsea/win32/
-##
-## Copyright (C) 2011-2015 Peter Breitenlohner <tex-live@tug.org>
-## You may freely use, modify and/or distribute this file.
-##
-AM_CPPFLAGS = -I$(top_builddir)/.. -I$(top_srcdir)/..
-AM_CPPFLAGS += -DWEB2CVERSION='"$(WEB2CVERSION)"'
-AM_CFLAGS = $(WARNING_CFLAGS)
-
-# Build WIN32 replacements for Unix shell scripts.
-bin_PROGRAMS = \
- mktexfmt \
- mktexlsr \
- mktexmf \
- mktexpk \
- mktextfm \
- mktexupd
-
-mktexfmt_SOURCES = \
- mktexfmt.c
-
-mktexlsr_SOURCES = \
- dirutil.c \
- mkpaths.c \
- mktex.h \
- mktexlsr.c
-
-mktexmf_SOURCES = \
- dirutil.c \
- getdestdir.c \
- mkpaths.c \
- mktex.h \
- mktexmf.c \
- mktexupd.c
-
-mktexpk_SOURCES = \
- dirutil.c \
- getdestdir.c \
- mkpaths.c \
- mktex.h \
- mktexpk.c \
- mktexupd.c
-
-mktextfm_SOURCES = \
- dirutil.c \
- getdestdir.c \
- mkpaths.c \
- mktex.h \
- mktextfm.c \
- mktexupd.c
-
-mktexupd_SOURCES = \
- mkpaths.c \
- mktex.h \
- mktexupdmain.c \
- mktexupd.c
-
-LDADD = ../libkpathsea.la
-
-install-exec-hook:
- cp -p $(DESTDIR)$(bindir)/mktexlsr$(EXEEXT) $(DESTDIR)$(bindir)/texhash$(EXEEXT)
-
-uninstall-hook:
- rm -f $(DESTDIR)$(bindir)/texhash$(EXEEXT)
-
-## Rebuild libkpathsea
-../libkpathsea.la: ${top_srcdir}/../kpathsea/*.[ch] ../paths.h
- cd .. && $(MAKE) $(AM_MAKEFLAGS) rebuild
-../paths.h:
- cd .. && $(MAKE) $(AM_MAKEFLAGS) rebuild
-
-EXTRA_DIST = ChangeLog
-