summaryrefslogtreecommitdiff
path: root/Build/source/texk/kpathsea/man/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/kpathsea/man/Makefile.am')
-rw-r--r--Build/source/texk/kpathsea/man/Makefile.am22
1 files changed, 6 insertions, 16 deletions
diff --git a/Build/source/texk/kpathsea/man/Makefile.am b/Build/source/texk/kpathsea/man/Makefile.am
index 6a929764624..f5860ec1bd3 100644
--- a/Build/source/texk/kpathsea/man/Makefile.am
+++ b/Build/source/texk/kpathsea/man/Makefile.am
@@ -1,6 +1,6 @@
## Makefile.am for the TeX Live subdirectory texk/kpathsea/man/
##
-## Copyright (C) 2009 Peter Breitenlohner <tex-live@tug.org>
+## Copyright (C) 2009 - 2011 Peter Breitenlohner <tex-live@tug.org>
## You may freely use, modify and/or distribute this file.
##
man_sources = \
@@ -23,19 +23,9 @@ include $(top_srcdir)/../am/man.am
man1_links = \
mktexlsr:texhash
-install-data-hook:
- @cd $(DESTDIR)$(man1dir) && \
- for s in $(man1_links); do \
- link=`echo $$s | sed 's,.*:,,'`; \
- file=`echo $$s | sed 's,:.*,,'`; \
- rm -f $$link.1; \
- echo "creating link '$$link.1' -> '$$file.1'"; \
- $(LN_S) $$file.1 $$link.1 || exit 1; \
- done
-
-uninstall-hook:
- @for s in $(man1_links); do \
- link=`echo $$s | sed 's,.*:,,'`; \
- rm -f $(DESTDIR)$(man1dir)/$$link.1; \
- done
+include $(top_srcdir)/../am/man1_links.am
+
+install-data-hook: install-man1-links
+
+uninstall-hook:uninstall-man1-links