summaryrefslogtreecommitdiff
path: root/Build/source/texk/kpathsea/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/kpathsea/Makefile.am')
-rw-r--r--Build/source/texk/kpathsea/Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/Build/source/texk/kpathsea/Makefile.am b/Build/source/texk/kpathsea/Makefile.am
index 03c0cfab060..17ab473710a 100644
--- a/Build/source/texk/kpathsea/Makefile.am
+++ b/Build/source/texk/kpathsea/Makefile.am
@@ -220,15 +220,13 @@ stamp-kpathsea: Makefile paths.h
echo '/* collecting all public kpathsea headers. */'; \
for f in config.h paths.h $(direct_headers); do \
echo "#include <kpathsea/$$f>"; \
- done ) >kpathsea.tmp
- @if cmp -s kpathsea.h kpathsea.tmp 2>/dev/null; then \
+ done ) >kpathsea.tmp && \
+ if cmp -s kpathsea.h kpathsea.tmp 2>/dev/null; then \
echo "kpathsea.h is unchanged"; \
else \
- echo "cp kpathsea.tmp kpathsea.h"; \
+ echo "generated kpathsea.h"; \
cp kpathsea.tmp kpathsea.h; \
- fi
- rm -f kpathsea.tmp
- date >$@
+ fi && rm -f kpathsea.tmp && date >$@
EXTRA_DIST += bsnl.awk cnf-to-paths.awk