summaryrefslogtreecommitdiff
path: root/Build/source/texk/gsftopk/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/gsftopk/configure.ac')
-rw-r--r--Build/source/texk/gsftopk/configure.ac38
1 files changed, 38 insertions, 0 deletions
diff --git a/Build/source/texk/gsftopk/configure.ac b/Build/source/texk/gsftopk/configure.ac
new file mode 100644
index 00000000000..dffe3176a5f
--- /dev/null
+++ b/Build/source/texk/gsftopk/configure.ac
@@ -0,0 +1,38 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl Copyright (C) 2009 Peter Breitenlohner <tex-live@tug.org>
+dnl
+dnl This file is free software; the copyright holder
+dnl gives unlimited permission to copy and/or distribute it,
+dnl with or without modifications, as long as this notice is preserved.
+dnl
+AC_INIT([gsftopk for TeX Live], [1.19], [tex-k@tug.org])
+AC_PREREQ([2.63])
+AC_CONFIG_SRCDIR([gsftopk.c])
+AC_CONFIG_AUX_DIR([../../build-aux])
+AC_CONFIG_MACRO_DIR([../../m4])
+
+dnl Common code for all programs using libkpathsea.
+KPSE_COMMON([gsftopk], [no-define])
+
+AC_CONFIG_HEADERS([c-auto.h:c-auto.in])
+
+dnl Checks for header files.
+AC_HEADER_SYS_WAIT
+AC_HEADER_TIME
+AC_CHECK_HEADERS([poll.h sys/time.h])
+
+dnl Checks for library functions.
+AC_FUNC_VFORK
+AC_TYPE_SIGNAL
+AC_CHECK_FUNCS([poll sigaction])
+
+if test "$ac_cv_header_poll_h" = no || test "$ac_cv_func_poll" = no; then
+ AC_CHECK_HEADERS([sys/select.h select.h])
+fi
+
+KPSE_KPATHSEA_FLAGS
+
+AC_CONFIG_FILES([Makefile])
+
+AC_OUTPUT