summaryrefslogtreecommitdiff
path: root/Build/source/texk/dvisvgm/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/dvisvgm/configure.ac')
-rw-r--r--Build/source/texk/dvisvgm/configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/Build/source/texk/dvisvgm/configure.ac b/Build/source/texk/dvisvgm/configure.ac
index ae3bd9b1ce8..835da7b8362 100644
--- a/Build/source/texk/dvisvgm/configure.ac
+++ b/Build/source/texk/dvisvgm/configure.ac
@@ -70,7 +70,8 @@ AS_IF([test "x$have_libgs" = "xno"],
[AC_MSG_WARN(PostScript support disabled)])])
fi
-if test "$HAVE_LIBGS" -eq 0; then
+if test -z "$HAVE_LIBGS" || test "$HAVE_LIBGS" -eq 0; then
+ AC_MSG_NOTICE([not linking to libgs, trying to arrange for dynamic loading])
# Windows (native or MinGW32) has neither <dlfcn.h> nor dlopen().
if test "x$kpse_cv_have_win32" = xno; then
# FreeBSD neither has nor requires libdl.
@@ -105,7 +106,7 @@ else
[gsversion=`cat gsversion`], [gsversion=], [gsversion=unknown])
AC_MSG_RESULT("$gsversion")
rm -f gsversion
- if test "$gsversion" -lt 831; then
+ if test -z "$gsversion" || "$gsversion" -lt 831; then
# current Ghostscript API was introduced in version 8.31
# older versions are not supported
AC_DEFINE(DISABLE_GS, 1, [Set to 1 if PostScript support should be disabled])