summaryrefslogtreecommitdiff
path: root/Build/source/texk/dvipsk/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/dvipsk/configure.ac')
-rw-r--r--Build/source/texk/dvipsk/configure.ac38
1 files changed, 38 insertions, 0 deletions
diff --git a/Build/source/texk/dvipsk/configure.ac b/Build/source/texk/dvipsk/configure.ac
new file mode 100644
index 00000000000..cd225818435
--- /dev/null
+++ b/Build/source/texk/dvipsk/configure.ac
@@ -0,0 +1,38 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl Copyright (C) 2009 Peter Breitenlohner <tex-live@tug.org>
+dnl
+dnl This file is free software; the copyright holder
+dnl gives unlimited permission to copy and/or distribute it,
+dnl with or without modifications, as long as this notice is preserved.
+dnl
+AC_INIT([dvipsk], [5.97], [tex-k@tug.org])
+AC_PREREQ([2.63])
+AC_CONFIG_SRCDIR([dvips.c])
+AC_CONFIG_AUX_DIR([../../build-aux])
+AC_CONFIG_MACRO_DIR([../../m4])
+
+dnl Common code for all programs using libkpathsea.
+KPSE_COMMON([dvipsk])
+
+AC_CONFIG_HEADERS([c-auto.h:c-auto.in])
+
+AC_CHECK_SIZEOF([int])
+
+AC_SEARCH_LIBS([pow], [m])
+
+KPSE_KPATHSEA_FLAGS
+
+AC_CONFIG_SUBDIRS([squeeze])
+
+AC_CONFIG_FILES([Makefile])
+
+dnl The subdirectory squeeze must be configured for the build system.
+dnl Can not share the cache file with the subdirectory!
+AC_CONFIG_COMMANDS_POST([AS_IF([test "x$cross_compiling" = xyes],
+[cache_file=/dev/null
+ ac_configure_args="$ac_configure_args --host='$build_alias' \
+ CC='$BUILDCC' CPPFLAGS='$BUILDCPPFLAGS'\
+ CFLAGS='$BUILDCFLAGS' LDFLAGS='$BUILDLDFLAGS'"])])
+
+AC_OUTPUT