summaryrefslogtreecommitdiff
path: root/Build/source/texk/dvipng/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/dvipng/configure.ac')
-rw-r--r--Build/source/texk/dvipng/configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/Build/source/texk/dvipng/configure.ac b/Build/source/texk/dvipng/configure.ac
index 44d552c2970..135f48276c2 100644
--- a/Build/source/texk/dvipng/configure.ac
+++ b/Build/source/texk/dvipng/configure.ac
@@ -98,8 +98,10 @@ KPSE_KPATHSEA_FLAGS
KPSE_ZLIB_FLAGS
KPSE_LIBPNG_FLAGS
KPSE_T1LIB_FLAGS
-KPSE_GD_FLAGS
KPSE_FREETYPE2_FLAGS
+kpse_save_FREETYPE2_INCLUDES=$FREETYPE2_INCLUDES
+kpse_save_FREETYPE2_LIBS=$FREETYPE2_LIBS
+KPSE_GD_FLAGS
dnl We have to check properties of libraries, either installed (system)
dnl libraries or unistalled (possibly libtool) ones from the TL tree.
@@ -117,6 +119,15 @@ AC_CHECK_FUNC([png_read_image],
[Define to 1 if you have the `png' library (-lpng).])],
[KPSE_MSG_ERROR([dvipng], [cannot find/use libpng])])
+set -x
+kpse_save_FREETYPE2_INCLUDES=$FREETYPE2_INCLUDES
+kpse_save_FREETYPE2_LIBS=$FREETYPE2_LIBS
+eval FREETYPE2_INCLUDES="$FREETYPE2_INCLUDES"
+eval FREETYPE2_LIBS="$FREETYPE2_LIBS"
+set +x
+AC_MSG_NOTICE([FREETYPE2_INCLUDES=\"$FREETYPE2_INCLUDES\"])
+AC_MSG_NOTICE([FREETYPE2_LIBS=\"$FREETYPE2_LIBS\"])
+KPSE_ADD_FLAGS([freetype2])
KPSE_ADD_FLAGS([gd])
AC_CHECK_FUNC([gdImageCreate],
[AC_DEFINE([HAVE_LIBGD], 1,
@@ -163,6 +174,8 @@ AC_CHECK_FUNCS([gdImageCreateTrueColor gdImageCreateFromJpeg gdImagePngEx gdImag
AM_CONDITIONAL([have_gif], [test "x$ac_cv_func_gdImageGif" = xyes])
KPSE_RESTORE_FLAGS
+FREETYPE2_INCLUDES=$kpse_save_FREETYPE2_INCLUDES
+FREETYPE2_LIBS=$kpse_save_FREETYPE2_LIBS
DVIPNG_VERSION=dvipng_version
AC_SUBST([DVIPNG_VERSION])