summaryrefslogtreecommitdiff
path: root/Build/source/texk/dvipng/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/dvipng/configure.ac')
-rw-r--r--Build/source/texk/dvipng/configure.ac21
1 files changed, 14 insertions, 7 deletions
diff --git a/Build/source/texk/dvipng/configure.ac b/Build/source/texk/dvipng/configure.ac
index 7c0d6aa9dd9..3cf49b7ad91 100644
--- a/Build/source/texk/dvipng/configure.ac
+++ b/Build/source/texk/dvipng/configure.ac
@@ -2,7 +2,7 @@
# the dvipng maintainers for it.
# Process this file with autoconf to produce a configure script.
-AC_INIT([dvipng], [1.10], [dvipng@nongnu.org])
+AC_INIT([dvipng], [1.9], [dvipng@nongnu.org])
AC_CONFIG_SRCDIR([dvipng.c])
AC_ARG_ENABLE(debug,
@@ -28,13 +28,9 @@ AC_ARG_WITH(gs,
GS=no
else
AC_PATH_PROG(GS,["$withval"])
- dnl --skip, karl GS_CHECK_DEVICES
fi],
[AC_CHECK_PROG(GS,gs,gs)
- if test -n "$GS"; then
- true
- dnl --skip, karl GS_CHECK_DEVICES
- else
+ if test -z "$GS"; then
GS="gs"
AC_MSG_WARN([Cannot find GhostScript in your PATH])
fi
@@ -55,6 +51,17 @@ AC_DEFUN([AC_GS_HAS_DEVICE],
fi
])
+GS_WARN=""
+AC_GS_HAS_DEVICE(pngalpha,
+ [GS_WARN="Your EPS inclusions will be cropped to the
+ boundingbox, and rendered on an opaque background.
+ Upgrade GhostScript to avoid this."
+ AC_GS_HAS_DEVICE(png16m,
+ [GS_WARN="Your EPS inclusions may not work.
+ Upgrade/install GhostScript to avoid this."])])
+if test -n "$GS_WARN"; then
+ AC_MSG_WARN([$GS_WARN])
+fi
ac_cv_lib_t1_T1_InitLib=yes
PSFONTS_O=""
@@ -175,7 +182,7 @@ fi
if test "$with_system_gd" = yes; then
OLD_LIBS=$LIBS
LIBS="$LDGD $LIBS"
- AC_CHECK_FUNCS([gdImageCreateTrueColor gdImageCreateFromJpeg gdImagePngEx gdImageCreateFromPngPtr gdImageGif FT_Library_Version])
+ AC_CHECK_FUNCS([gdImageCreateTrueColor gdImagePngEx gdImageGif gdImageJpeg])
LIBS=$OLD_LIBS
else
AC_DEFINE([HAVE_GDIMAGECREATETRUECOLOR])