summaryrefslogtreecommitdiff
path: root/Build/source/texk/cjkutils/scripts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/cjkutils/scripts/Makefile.am')
-rw-r--r--Build/source/texk/cjkutils/scripts/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/Build/source/texk/cjkutils/scripts/Makefile.am b/Build/source/texk/cjkutils/scripts/Makefile.am
new file mode 100644
index 00000000000..766e977d633
--- /dev/null
+++ b/Build/source/texk/cjkutils/scripts/Makefile.am
@@ -0,0 +1,30 @@
+#
+
+dist_bin_SCRIPTS = \
+ bg5latex \
+ bg5pdflatex \
+ cef5latex \
+ cef5pdflatex \
+ ceflatex \
+ cefpdflatex \
+ cefslatex \
+ cefspdflatex \
+ gbklatex \
+ gbkpdflatex \
+ sjislatex \
+ sjispdflatex
+
+install-exec-hook:
+ @cd $(DESTDIR)$(bindir) && \
+ for p in latex pdflatex; do \
+ echo "$(LN_S) gbk$$p bg5+$$p"; \
+ rm -f bg5+$$p; $(LN_S) gbk$$p bg5+$$p; \
+ done
+
+uninstall-hook:
+ rm -f $(DESTDIR)$(bindir)/bg5+latex $(DESTDIR)$(bindir)/bg5+pdflatex
+
+## Eventually delete these files
+##
+EXTRA_DIST = Makefile.in.orig
+