summaryrefslogtreecommitdiff
path: root/Build/source/texk/bibtex-x/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/bibtex-x/configure.ac')
-rw-r--r--Build/source/texk/bibtex-x/configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/Build/source/texk/bibtex-x/configure.ac b/Build/source/texk/bibtex-x/configure.ac
index 0143f200842..80f874a6266 100644
--- a/Build/source/texk/bibtex-x/configure.ac
+++ b/Build/source/texk/bibtex-x/configure.ac
@@ -1,6 +1,8 @@
+dnl $Id$
dnl Process this file with autoconf to produce a configure script.
dnl
-dnl Copyright (C) 2009-2013 Peter Breitenlohner <tex-live@tug.org>
+dnl Copyright 2015-2021 Karl Berry <tex-live@tug.org>
+dnl Copyright 2009-2015 Peter Breitenlohner <tex-live@tug.org>
dnl
dnl This file is free software; the copyright holder
dnl gives unlimited permission to copy and/or distribute it,
@@ -28,8 +30,13 @@ KPSE_CXX_HACK
AC_SEARCH_LIBS([pow], [m])
+if test "x$enable_bibtexu" != xno; then
+ dnl As of ICU 65.1, ICU requires -lpthread on x86_64-linux and, most
+ dnl likely, on other platforms. See upmendex/configure.ac for more info.
KPSE_KPATHSEA_FLAGS
+KPSE_SEARCH_LIBS([PTHREAD_LIB], [pthread_create], [pthread])
KPSE_ICU_FLAGS([icuio icui18n], [--ldflags-icuio])
+fi
AM_CONDITIONAL([BIBTEX8], [test "x$enable_bibtex8" != xno])
AM_CONDITIONAL([BIBTEXU], [test "x$enable_bibtexu" != xno])